The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID

PaliBeastMode23 101 Reputation points
2021-02-21T00:47:33.577+00:00

The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID {2593F8B9-4EAF-457C-B68A-50F6B8EA6B54} and APPID {15C20B67-12E7-4BB6-92BB-7AFF07997402} to the user DESKTOP-L859GOU\Mudda SID (S-1-5-21-3310432888-172196483-2371647838-1001) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool. i keep getting this error when im only playing this one certain game it continues to crash please help me what steps do i need to take in order for this error to go away! thank you

Windows 10 Compatibility
Windows 10 Compatibility
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Compatibility: The extent to which hardware or software adheres to an accepted standard.
460 questions
{count} votes

8 answers

Sort by: Most helpful
  1. Collen Genine 31 Reputation points
    2022-03-31T21:19:02.503+00:00

    found the solution in the dcom you see for example for me it was perappruntimebroker right click select permissions in the security tab select edit in the launch and activation permission there you will see the account that need the permission for me it was (account-unknown Sxxx.xxx.xx.xx.xx and so on
    188845-schermafbeelding-2022-03-31-225331.jpg

    the solution now go to the registry to do so winkey+r type regedit then go to Computer\HKEY_CLASSES_ROOT\CLSID\and the number of your displayed error

    on the right pane you see the reference of your dcom app for me perappruntimebroker so that you see you have the correct dcom app ;-)
    188943-registry.jpg

    right click on the key and select permission and click the advance special permission to give yourself permission to change the key so select change the owner
    choose your admin account or administrator press ok select the checkbox replace the owner and replace all child object press ok
    your back now to the permission and search for the responsible account so in my case unknown account s01-xxx xx x xx x and give this full permission press ok
    reboot the pc and your done

    Strange that nobody posted an solution
    cheers

    6 people found this answer helpful.

  2. Sumutiu Marius 25 Reputation points
    2023-05-27T12:21:11.32+00:00

    In my case, this error had nothing to do with the permissions. If you have the "Microsoft Vulnerable Driver Blocklist" enabled in Device Security -> Core Isolation, you also have to provide the CI Policies for it.

    If you somehow get rid of the error by setting up elevated permissions, that just bypasses the "Microsoft Vulnerable Driver Blocklist" (hence why you're not getting the error anymore) rather than address the issue.

    Microsoft (as always) enables things by default but fails to provide users with how to properly implement these. And because of that, they'd rather suggest to ignore these errors/warnings in the Event Viewer rather than address them.

    To fix this:

    1. Download and extract the VulnerableDriver Blocklist from here: https://aka.ms/VulnerableDriverBlockList
    2. Rename either the Audit or Enforced files from the VulnerableDriverBlockList folder to "SiPolicy". (Suggest the Audit file)
    3. Copy the file to %windir%\system32\CodeIntegrity
    4. Check your PC's architecture by running in CMD: echo %processor_architecture%
    5. Download the Refresh Policy tool for your PC'S architecture from here: https://aka.ms/refreshpolicy
    6. Run the RefreshPolicy software.
    7. Restart.
    4 people found this answer helpful.

  3. Carl Fan 6,836 Reputation points
    2021-02-22T06:33:22.167+00:00

    Hi,
    This is usually related to the permissions of the DCOM component. Most times it isn't an issue, if we want to clear this event log, we could modify the CLSID and appid under registry /DCOM cmponent.

    1. Open the registry editor as an administrator and nagvigate to HKEY_CLASSES_ROOT\CLSID{2593F8B9-4EAF-457C-B68A-50F6B8EA6B54}. If you are in the right location, you also see the APPID as a value. 2.Remember the application name, you can see in the Data column, the corresponding Name column shows (Default).
    2. Right click the CLSID{2593F8B9-4EAF-457C-B68A-50F6B8EA6B54} and click Permissions, then choose Advanced.
      In the advance security setting window, click Change and type your administrator account. Then click OK.
      In the "Permissions for..." windows, select the Administrators and activate the Full Permissions checkbox.
    3. Repeat step 1 to 3 to configurate APPID{15C20B67-12E7-4BB6-92BB-7AFF07997402}.
      Next to config DCOM permission:
    4. Click Start -> Run -> Type -> dcomcnfg, expand Component Services -> Computers -> My Computer -> DCOM Config.
    5. Click View -> Detail -> Now you will get Application Name and Application ID in right side.
    6. Scroll down and find the application ID {15C20B67-12E7-4BB6-92BB-7AFF07997402} -> Right Click -> Properties and select the Security tab.
    7. Click Customize under "Launch & Activation Permission" -> click Edit -> Add in the account NT AUTHORITY\SYSTEM and set local launch and local activation.
      Hope this helps and please help to accept as Answer if the response is useful.
      Best Regards,
      Carl
    2 people found this answer helpful.

  4. Kapil Arya 7,871 Reputation points MVP
    2021-02-22T05:12:03.707+00:00

    Hello,

    From https://support.microsoft.com/en-in/help/4022522/dcom-event-id-10016-is-logged-in-windows-10-windows-server, Microsoft says:

    "These events can be safely ignored because they do not adversely affect functionality and are by design. This is the recommend action for these events."

    If you still like to fix, refer this guide:

    https://www.kapilarya.com/fix-event-10016-error-the-application-specific-permission-settings-do-not-grant-local-activation-permission-in-windows-10

    Hope this helps!

    Note: Included link in this reply refers to blog post by a trusted Microsoft MVP.

    1 person found this answer helpful.

  5. Legion 6 Reputation points
    2021-09-08T10:12:37.113+00:00

    @Alejandro Maya

    Generally: If DCOM Config settings are greyed out or like in your case - the permissions are denied even you made changes like @Carl Fan describes in his solution, than you should simply RE-RUN the Component Services Management Console.

    Simply said:

    • Re-run the Component Services Management Console (dcomcnfg.exe) and you should now be able to modify the settings.
    1 person found this answer helpful.