Can't create cosmos sql database with shared throughput

Aske Jenstrup Olsson 6 Reputation points
2020-05-20T11:16:24.8+00:00

Hi,

After deploying a Cosmos-db sql instance through an arm template I cannot create databases with shared throughput. I get the following error:

Message: {\"code\":\"Forbidden\",\"message\":\"Message: {\\\"Errors\\\":[\\\"DataBase SharedOffer is Disabled for your account, for further queries please contact support.\\\"]

If I change my provisioning scripts to set throughput on containers instead (not preferred) I will get the following error when creating containers:

{"code":"Forbidden","message":"Message: {\"Errors\":[\"Reached the pre-approved storage limit for the database 
account. Please contact Azure support to increase this limit.\"]

Is it something in my subscription I need to tune or some options I've missed?
Regards

Azure Cosmos DB
Azure Cosmos DB
An Azure NoSQL database service for app development.
1,530 questions
{count} votes