Unable to upgrade tabular level to compatibility level to 1500

Nama, Srikanth 1 Reputation point
2020-05-20T15:20:30.617+00:00

We are in the midst of upgrading our tabular models compatibility level to 1500. They are currently on 1200 and they are on SSAS not Azure Analysis Services. We were successful in converting most of them to 1500 and deploy them.. However, we are not able to convert couple of them and getting an error when trying to deploy them. FYI, I was able to upgrade them to 1500, process & build successfully in VS2019 but not able to deploy to our Analysis server. I am getting the following error and as you can see the error is not telling much. Does anyone encountered similar problem has any idea(s) on how to resolve this issue?

Error :

Failed to save modifications to the server. Error returned: ‘The operation cannot be performed because it references an object or property that is unavailable in the current edition of the server or the compatibility level of the database.’

Appreciate your input and help.

Thanks,
SN

Azure Analysis Services
Azure Analysis Services
An Azure service that provides an enterprise-grade analytics engine.
444 questions
{count} votes

2 answers

Sort by: Most helpful
  1. KranthiPakala-MSFT 46,442 Reputation points Microsoft Employee
    2020-05-22T16:59:52.293+00:00

    HI @NamaSrikanth-3814 ,

    Thank you for reaching out. Could you please try updating the compatibility level manually in SSMS (with TMSL CreateOrReplace script) ?

    1 person found this answer helpful.
    0 comments No comments

  2. Srikanth NAMA 1 Reputation point
    2020-05-29T12:34:47.457+00:00

    Yes, it worked. But I was wondering why it(deploying) didn't work from VS but worked through SSMS.