Error adding VM to RDS virtual desktop collection

Stijn van den Berg 1 Reputation point
2021-02-22T15:48:57.013+00:00

Hi,
I'm trying to setup a virtual desktop environment with Windows server 2019 VDI.

I have my main Windows server that runs a hypervisor, called the HV server.
On that server run 2 virtual machines running Windows server 2019.

One of them runs the Active Directory, DNS and DHCP server, and the other one hosts the remote desktop services or RDS.
70732-image.png

The host machine runs the RD virtualization host server and Hyper-V.

Now when I try to create a new virtual desktop collection. I just need to create a single virtual machine.
I'm using the following setting:
70733-image.png

Then I choose my virtual machine to add to the collection:
70751-image.png

Then when I try to click on 'ok', I get the following message:
70667-image.png

I have no idea what this error means,
I literally cannot find anything on the internet about this error.
When i just try to use the setting with managed virtual desktops, I choose my VM template and then get the following error:
70705-image.png

I have tried the following:

  1. Changing the permissions of the vhdx file.
  2. Changing the permissions of the Domain users group.
  3. Adding Domain Adminstrators to the user able to use the VM.
  4. Using both generation 1 & 2 VM's.

So far nothing has helped.

Can anyone please tell me what I'm doing wrong?

Some help would be much appreciated!

Windows Server 2019
Windows Server 2019
A Microsoft server operating system that supports enterprise-level management updated to data storage.
3,545 questions
Hyper-V
Hyper-V
A Windows technology providing a hypervisor-based virtualization solution enabling customers to consolidate workloads onto a single server.
2,600 questions
Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,340 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Grace HE 1,241 Reputation points
    2021-03-08T07:43:29.913+00:00

    Hi,
    I am sincerely sorry that I can't offer some suggestions on this issue. You can contact for Microsoft Support.
    Global Customer Service phone numbers (microsoft.com)
    https://support.microsoft.com/en-us/topic/global-customer-service-phone-numbers-c0389ade-5640-e588-8b0e-28de8afeb3f2

    ---If the suggestions above are helpful, please ACCEPT ANSWER. Really appreciate. This will also help others with similar issue to find this post quickly. ---

    0 comments No comments

  2. Steve Peace 1 Reputation point
    2021-07-20T19:33:58.777+00:00

    Was this ever resolved? I am experiencing the a similar issue. I had a test VDI setup that was working, albiet with some issues. I wiped it all out and started from scratch to setup the production environment. I have setup the RDS Session Host and that is working fine. I have published apps and they are accessible. I then went back and added the roles for a virtual machine-based desktop deployment. I then added my three clustered Hyper-V servers that are configured using Storage Spaces Direct for the storage and clustering of my Hyper-V images. I was successfully able to add the features. Now when I go to add a Virtual Desktop Collection, I get as far as selecting the Virtual Desktop Template. When I select it and click next I get the dialog box titled "The virtual Desktop template must be in a stopped state", just like above. I have verified that it is in a stopped state. I have verified that it has been sys-prepped. I have built multiple vm's and sysprepped them, I am at my wits end. I cannot figure out where the issue is. Everything looks right. Unfortunately I do not know which event logs to look at to try and diagnose the error. I have checked the logs on the broker, and all 3 of my clustered Hyper-V servers.

    I have tried creating the collection and then specify VM's to add as well. When I do that, I do get further through the wizard, but then it fails with the following:
    116300-image.png

    My AD infrastructure is completely separate from the Hyper-V cluster. That is all working as far as I can tell. It's just strange that it was working, but when I removed the test broker, test gateway, test licensing serevr. and test web access server and rebuilt all of them that is when it quit working. The only servers that stayed the same was the physical servers that are clustered and are now configures to be my Virtualization hosts for the new broker, and the RD Session host that has all of our applications.

    Any help would be greatly appreciated

    0 comments No comments