Teams Meeting lobby control via OnlineMeetingUpdate (delegated permissions) doesn't work once the meeting has started

Paul Nearney 1 Reputation point
2021-02-23T13:44:37.86+00:00

Prior to a Teams meeting starting (i.e. before an attendee joins) I am able to change the lobby bypass settings of a meeting by calling Update onlineMeeting as the meeting organizer, using delegated permissions, and passing the following request body:

{  
  "lobbyBypassSettings": {  
    "scope": "everyone"  
  }  
}  

This works well, and when I query the meeting in Graph, view the meeting options in-meeting or on the meeting options page, and try and join the meeting, all behaviour is as expected.

However, as soon as an attendee has joined the meeting, I see the following behaviour when I call Update onlineMeeting:

  • The call succeeds with 200OK, as expected
  • The meeting options are changed, both in-meeting and on the meeting options page, as expected
  • Querying the meeting using Graph returns the meeting with the options I've set, as expected
  • The lobby settings do not take effect in the meeting - i.e. if I've set the lobby bypass to "Only Me", attendees still bypass the lobby, and vice versa - not expected!
  • I've tried this using both delegated and application permissions (with the application access policy applied), and I've tried sending other updates into the meeting such as subject, startDate, endDate, to see if this somehow triggers the settings to take effect. I've also tried joining the call as a bot, and triggering various operations there to see if there's some way to make the setting take hold - but no joy.

Is there anything I can do to get this working?

Microsoft Teams Development
Microsoft Teams Development
Microsoft Teams: A Microsoft customizable chat-based workspace.Development: The process of researching, productizing, and refining new or existing technologies.
2,965 questions
{count} votes