Remote Desktop Gateway not connecting

Imran Shabir 21 Reputation points
2021-02-23T14:31:54.853+00:00

Hi,

Hope your keeping well and safe,

I have setup a RDG server with features Manager and Licensing on the same box, it was was working but now its stopped however we received a license issue on when using the gateway for multiple connections to a single server. Any help would be useful please.

Spec:
Server 2016 STD
vCPU: 6
Memory: 6GB

71173-rdp-config.png
71183-rdp-cert-error.png
71145-rdp-cert-error-2.png
71191-cert-descrip.png
71192-trusted-root-cert.png

Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,332 questions
Windows Server Security
Windows Server Security
Windows Server: A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.Security: The precautions taken to guard against crime, attack, sabotage, espionage, or another threat.
1,762 questions
0 comments No comments
{count} votes

Accepted answer
  1. Karlie Weng 15,676 Reputation points Microsoft Vendor
    2021-02-24T07:02:30.053+00:00

    Hello @Imran Shabir

    To trust the self-signed Root CA on the client, you will need to export the CA certificate from the server, then import the certificate as a Trusted Root Certification Authority on the client computer.

    From http://support.microsoft.com/kb/555252:

    Requesting the Root Certification Authority Certificate by using command line:
    a. Log into the Root Certification Authority server with Administrator Account.
    b. Go to "Start" -> "Run" -> and write "Cmd" and press on "Enter" button.
    c. To export the Root Certification Authority server to a new file name "ca_name.cer"
    write: "certutil -ca.cert ca_name.cer".

    Next, you will copy the certificate to the client machine.

    1. Double-click on the certificate on the client machine.
    2. Choose "Install Certificate..." on the General tab, then click Next.
    3. Choose "Place all certificates in the following store", then choose "Browse..."
    4. Select "Trusted Root Certification Authorities", and click OK.
    5. Click Next, then click Finish.
    6. You should be able to connect to the RD Gateway on that client machine now. You will need to do this on each client machine that you want to connect from.

    Best Regards
    Karlie

    ----------

    If the Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

3 additional answers

Sort by: Most helpful
  1. Imran Shabir 6 Reputation points
    2021-02-24T07:55:22.7+00:00

    Hi @Karlie Weng

    I installed it using Local Machine and Local user for Trusted Root Certification Authority and i still got the unknown publisher.

    Kind Regards
    Imran


  2. Cláudio Rodrigues 1 Reputation point
    2021-02-26T04:15:48.337+00:00

    Why not use a real certificate? Let's Encrypt is free. Can be issued/renewed using PowerShell (Posh-ACME module). Way better approach.
    That said your certificate is one thing, the Root CA is another. The Root goes to the Trusted Root folder, the actual cert to the certificates. Machine level, not user.

    CR

    0 comments No comments

  3. Imran Shabir 6 Reputation points
    2021-03-10T08:46:28.097+00:00

    Hi @Cláudio Rodrigues

    Thank you for the response,

    Apologies i forgot about this ticket, i got arround this by using a Self-signed Cert and it worked. even tho RDG Certificates say untrusted its working. I got consultancy help and it was a wild card/internal CA cert issue.

    Thanks

    0 comments No comments