IIS 8.5 AAR reverse proxy, Block X-Power-By Header

Craig Garland 286 Reputation points

Hi All,

So I have been requested by a client to block the X-power-by header (and other header but I managed to block them.)

I have tried a few option on the web for blocking X-Power-by header but this does not seem to be working on the AAR.

I was able to do it on the Internal server by adding <CustomHeaders> remove name="X-Powered-By" </CustomeHeaders>

Unfortunately I now seem to get the AAR responding to the X-Powered-By header. I now get this "X-Powered-By ARR/3.0"

Does anyone know how I can block the AAR server from sending a response?

I have tried <CustomHeaders> remove name="X-Powered-By" </CustomeHeaders> on the AAR.

Thanks for your time.


Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,449 questions
0 comments No comments
{count} votes

Accepted answer
  1. Teemo Tang 11,366 Reputation points

    Remove Unwanted HTTP Response Headers

    In fact, for iis issue, you could ask for help from our iis forum.
    The reason why we recommend posting appropriately is you will get the most qualified pool of respondents, and other partners who read the forums regularly can either share their knowledge or learn.
    Thanks for your understanding and cooperating.


    If the Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

3 additional answers

Sort by: Most helpful
  1. Leon Laude 85,701 Reputation points

    Hi @Craig Garland ,

    I suggest asking the subject matter experts in the dedicated IIS forum over here:


    (If the reply was helpful please don't forget to upvote and/or accept as answer, thank you)

    Best regards,

    0 comments No comments

  2. Craig Garland 286 Reputation points


    I did go to Forums.iis.net first but could not find a solution and as I did not seem to have an account there I though it might be best to ask here.

    I will try the fix suggestion over the weekend and see how it goes.


  3. Craig Garland 286 Reputation points


    I ended up using Step 3 in the link to resolve the issue.


    0 comments No comments