Language inconsistency in Windows

Jaap Hoetmer 1 Reputation point

Hi all, Living in a country where English is not the spoken language I often find myself in a situation where I find inconsistent language-related behavior in Windows and its applications. When the system is installed in the local language, with local keyboard support, and local language applications, all is fine. Most installers detect the local language settings properly (Swiss French), and install a localized version. Fine. However, when there's a preference or requirement to install an English version of Windows, things start to get complicated. In combination with regional keyboard and date and time settings, it suddenly becomes a mixed installation of English and French. Parts of the OS suddenly show text in the local language, applications you want to install 'think' I need the localized version installed, search engines show results in the local language, etc, etc. Why? If I select an English language OS, I want everything I install on it to match that language, irrespective of the keyboard and date and time formats. Search results should show in the English language, not the local language. When updates arrive, the keyboard often gets reset and shows all possible keyboard combinations for the local country (Switzerland has multiple languages and keyboard layouts). Where is this behavior coming from? Can this be altered in such a way that I can work correctly with English language Windows without that these inconsistencies appear? Having just finished a new Server 2019 installation, and setting the regional options as desired, I find myself having to select specifically English software products, because the 'detection' of the OS language fails miserably. I guess regional settings trump the OS language settings, strangely enough. Thanks for any feedback you may have.

Windows Server 2019
Windows Server 2019
A Microsoft server operating system that supports enterprise-level management updated to data storage.
3,537 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Carl Fan 6,836 Reputation points

    According to your description, I consider that you could check the settings below:
    Control Panel>Clock and Region>Region>Administrative

    Hope this helps and please help to accept as Answer if the response is useful.
    Best Regards,

    0 comments No comments