You'll need a new app to open this windowsdefender/calculator/.. link

Cihan NMK 6 Reputation points


I have connected 2 new PC's and 1 laptop to an exsisting AD.

When I log in with a non-admin domain account the store is not available as are the 'basic' windows 10 apps. (windowsdefender, calculator, etc)

I can see the Windows defender shield icon next to the clock but clicking it to open it gives the error message as seen in the subject.

Using the calculator shortcut on the keyboard gives the same message but with calculator instead of windowsdefender.

I found a couple of tips which did not solve the issue.

  1. typing the following in an elevated powershell.

Add-AppxPackage -Register -DisableDevelopmentMode “C:\Windows\SystemApps\Microsoft.Windows.SecHealthUI_cw5n1h2txyewy\AppXManifest.xml”
2. using the cortana workarround.

I managed to make the apps available on 1 of the devices by resetting/reinstalling windows.

It did not work on the other PC and also not on the laptop

When Logged in as local admin or domain admin the previously mentioned apps are all available and running properly.

Device information:


Dell OptiPlex 3080@ Windows 10 Pro 20H2


Dell Vostro 3500@ Windows10 Pro 20H2

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
10,973 questions
0 comments No comments
{count} vote

4 answers

Sort by: Most helpful
  1. Saket Ranjan 46 Reputation points

    If this is a problem you're having after upgrading to Windows 11, the below command should work :

    Get-AppxPackage Microsoft.SecHealthUI -AllUsers | Reset-AppxPackage

    Run this command on PowerShell as an administrator.

    9 people found this answer helpful.

  2. AliceYang-MSFT 2,081 Reputation points


    Thank you for the details you provided and troubleshooting you've done.

    Are there other PCs in this AD except the reinstalled one? Can you please try to log in with non-admin domain account on those PCs and check whether the issue happens too?

    Please refer to MaritzaCapiro's answer You'll need a new app to open this windowsdefender

    1) launch powershell (run as administrator)
    2) Set-ExecutionPolicy Unrestricted
    3) Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}
    Restart your system

    If the issue persists, please let me know and we can continue our troubleshooting.

    If the Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    3 people found this answer helpful.
    0 comments No comments

  3. Tadeo 1 Reputation point

    For me this solution is not working.
    Have the same problem with apps when user is logged in into domain, when admin is logged all apps working perfect.
    For example: App Pictures - cannot print (printer window where u can select printer and etc. is not opening).
    Windows Defender showing yellow warning and cannot be opened.


    0 comments No comments

  4. Iñigo Acha (Etsa) 1 Reputation point

    Perfect my man, all working again, thanx for the command.