Error caa5009d

Richard 111 Reputation points
2021-02-24T15:52:01.227+00:00

We keep getting the error caa5009d happen at random on some of our machines. I have not been able to tie it down to one specific cause. 1 instance is the user changed their email password, and then the next time teams loaded the error happened. For information we have a separate active directory infrastructure, from where our Office 365/Teams is running. There are no links from the domain that the machines use to Azure AD on the Office 365 tennet. I have logs from machines that’s its happened on. It can be fixed by deleting the user profile in some instances, others deleting the teams folder from the user profile, and the re-loading it has worked. Other times that has failed and a new profile is required. If anyone can help with this error that would be great! Thanks! Richard

Microsoft Teams
Microsoft Teams
A Microsoft customizable chat-based workspace.
9,403 questions
{count} votes

Accepted answer
  1. Richard 111 Reputation points
    2021-03-17T09:04:57.247+00:00

    so it seems like that adding the Microsoft account in settings.... accounts... access work or school. Then clicking connect and entering the email address that you use with Teams seems to resolve the issue.

    1 person found this answer helpful.

8 additional answers

Sort by: Most helpful
  1. Anthony Fitzgerald 125 Reputation points
    2023-10-30T13:43:11.9+00:00

    The solution that worked for me was to Update the Microsoft App Installer through the Microsoft Store. It needed an update. After that, Teams For Business installed fine.

    25 people found this answer helpful.

  2. Sharon Zhao-MSFT 25,076 Reputation points Microsoft Vendor
    2021-02-25T02:18:24.207+00:00

    @Richard ,

    Do you mean this error code pops up after users’ password changed?

    To determine if this is an account side issue, you could try to log in Teams web client(https://teams.microsoft.com) and observe the result.

    If it works well, try to clear Teams client cache and windows credentials as below:

    1.Open a browser, reset all settings. 2.Quit Teams and delete the following files: - %appdata%\Microsoft\teams\application cache\cache - %appdata%\Microsoft\teams\blob_storage - %appdata%\Microsoft\teams\Cache - %appdata%\Microsoft\teams\databases. - %appdata%\Microsoft\teams\GPUcache - %appdata%\Microsoft\teams\IndexedDB - %appdata%\Microsoft\teams\Local Storage - %appdata%\Microsoft\teams\tmp 3. In Windows Credential Manager, please select Windows Credentials, under Generic Credentials, please delete all entries with a line meteams_.

    Also, make sure your client is the latest version.

    Besides, perform a clean boot to eliminate whether this issue is caused by software conflicts.


    If the response is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    1 person found this answer helpful.

  3. Rachel Gomez 166 Reputation points
    2022-08-23T06:27:40.827+00:00

    Ways to fix
    Fix 1: Run the application in Compatibility Mode.
    Fix 2: Clear the Cache and Credentials of Teams Application.
    Fix 3: End the tasks running in the background.
    Fix 4: Ensure Firewall is not blocking the access to Teams App.

    Greeting,
    Rachel Gomez

    1 person found this answer helpful.
    0 comments No comments

  4. Chetan Gandhavadi 1 Reputation point
    2021-03-23T19:13:59.47+00:00

    delete all the microsoft folder in the user profile
    uninstall teams
    uninstall "teams-system wide install"
    and then installing teams again worked for me

    0 comments No comments