Sharepoint 2019 - tasks list filter does not get applied to 'empty' assigned to fields

Vivek S 81 Reputation points
2021-02-25T06:58:17.023+00:00

Hi,

On-prem 2019, when I try to apply filter to the 'assigned to' column, I am unable to filter out 'empty' assigned to fields. It works well when I filter by a user name. If I select a user and the 'empty' option, then I am able to filter by the user name and the empty columns, however, unable to filter by 'empty' values by themselves. Please note that on a custom list I am able to filter by 'empty' people/group column values.

Thanks
Vivek

SharePoint Server Management
SharePoint Server Management
SharePoint Server: A family of Microsoft on-premises document management and storage systems.Management: The act or process of organizing, handling, directing or controlling something.
2,866 questions
{count} votes

Accepted answer
  1. ChelseaWu-MSFT 6,316 Reputation points
    2021-03-03T02:16:16.087+00:00

    Hi Vivek, we have found similar issue in our SharePoint Server 2019 environments.

    The engineering team from Microsoft has been aware of it and working on the fix, which might be included in the coming updates.

    It is recommended to keep the product up to date with latest security updates and see if the issue will be resolved then.

    Thank you for your patience and understanding.


    If an Answer is helpful, please click "Accept Answer" and upvote it.
    **Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread. **


1 additional answer

Sort by: Most helpful
  1. ChelseaWu-MSFT 6,316 Reputation points
    2021-03-10T09:30:02.347+00:00

    Hi Vivek, the fix for this issue is released with the March 9, 2021 security update for SharePoint Server 2019.

    Please find the download entrance here: http://www.microsoft.com/download/details.aspx?familyid=93aae8bc-8253-4df6-a1cf-7554eb0f8eda

    Quoting which,

    Fixes an issue in which filtering out list items by using the Empty option on the Date column in a Task list doesn't work.