Can't open previous versions of any folder - Windows 10 Version 2004

Jim Millerick 31 Reputation points


I went to restore one of my documents and when I went to previous versions I couldn't click open for the file or folders. It shows there are versions of the folder but I can't open any of them - it doesn't give an error.

Can I wipe out all my previous versions and start from scratch? If so how please.

FYI - I've tried sfc /scannow and chkdsk /f no errors.

I have no idea if this is related to h2 but I used to do this all the time before I updated without issue - could be just a coincidence.

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
7,500 questions
0 comments No comments
{count} vote

8 answers

Sort by: Most helpful
  1. Jenny Feng 13,801 Reputation points

    @Jim Millerick
    If File History isn’t enabled, then you may not be able to restore a previous version in Windows 10 unless you’re already syncing your files to cloud storage.
    You can check if File History is enabled in the Windows Settings menu. Right-click the Start menu and select the Settings option to begin.
    In the Windows Settings menu, select Update & Security > Backup. Underneath the Back up using File History option, the drive you currently use for File History backups will be listed. If one isn’t listed, then you’ll need to enable File History by selecting the Add a drive option.
    Unfortunately, there aren’t many options to help you restore previous versions in Windows 10 if you don’t already have a backup system in place.
    Hope above information can help you.


    If the Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    1 person found this answer helpful.
    0 comments No comments

  2. Jim Millerick 31 Reputation points

    I just went to system protection. I hit delete and disabled it. I then went back and enabled it and did a backup. I then tried to open a previous version of a folder and same issue - nothing happens.

    0 comments No comments

  3. Jim Millerick 21 Reputation points

    Thanks - I forgot to mention - last night if I go to turn that off, I get an error message 0x80070020 so I can't turn that off.

    0 comments No comments

  4. Jim Millerick 21 Reputation points

    Thanks again for your reply - I spent some time exploring it and for some reason even though the location and drive letter of my backups hadn't changed, it lost it's connection to the local drive for the backups for some reason. I removed the backups, disabled it, rebooted, reassigned that drive letter and backups may have occurred last night. I'll need to wait a few days to find out. I was able to restore 1 file from last night's backup. I'll see how it goes. I appreciate the big assist!

    0 comments No comments

  5. Jim Millerick 21 Reputation points

    Unfortunately I haven't fully fixed it yet. folders show previous versions but you can't open folders. I can open and restore individual files now.