Form Recognizer Error: Check if you have unexpired read/write/list/delete permission to blob container/blob.

Eden Corbin 66 Reputation points
2021-02-25T09:22:06.717+00:00

I am having trouble reconnecting to a blob I successfully connected to just fine the other day in the sample labeling tool docker project with details I folled here originally (and reconnecting the other day) https://learn.microsoft.com/en-us/azure/cognitive-services/form-recognizer/quickstarts/label-tool?tabs=v2-1. I have gone to my storage account multiple times and I use Storage Explorer right click the model folder, click get shared access signature, select all permissions, change start and end time to easily cover today, create this SAS, then I copy paste this into connections, it then says its fine, I then open the cloud project and it finds my model from the connection, however it then says (after clicking my model): Error: Check if you have unexpired read/write/list/delete permission to blob container/blob. What could this be?

Azure Blob Storage
Azure Blob Storage
An Azure service that stores unstructured data in the cloud as blobs.
2,616 questions
Azure AI Document Intelligence
Azure AI Document Intelligence
An Azure service that turns documents into usable data. Previously known as Azure Form Recognizer.
1,530 questions
{count} votes

5 answers

Sort by: Most helpful
  1. PHH 21 Reputation points
    2021-07-08T12:30:48.427+00:00

    Once you change the settings of your containers with URL etc., at the project level you need to first unselect the connection name and then select it again. It took me a few hours to figure it out.

    4 people found this answer helpful.

  2. Kais Hefaiedh 116 Reputation points
    2021-07-26T20:08:06.07+00:00

    I have the same problem and i tried all what i read here bu not work.
    after that i changed my CORS :Allowed origins, Allowed headers, exposed headers.

    i set * in these fields and it works fine. I had access to the container now.

    3 people found this answer helpful.

  3. GiftA-MSFT 11,161 Reputation points
    2021-02-26T00:50:04.28+00:00

    Hi, thanks for reaching out. How much time did you specify when getting shared access? Can you try setting start time to be at least 15mins in the past? Here are some best practices to review. Let us know if it helps.


  4. Jones Jebaraj 1 Reputation point Microsoft Employee
    2021-07-08T07:22:37.763+00:00

    Hi.. am also getting the same error. I tried including the /subfolder etc. but still facing the same issue.

    The public access level for the storage account is "Container" and there are no access policy. I have mentioned the start date / time as yesterday's date as well.

    0 comments No comments

  5. Salik Rafiq 1 Reputation point
    2021-07-16T10:04:21.383+00:00

    Hello, I ran into this issue and the solutions was to delete the connection and recreate. Than it worked.

    0 comments No comments