Mysql config parameter innodb page size to be increased in Azure mysql db

Abdul Hayee 1 Reputation point

Hi i am new to Azure and planning on shifting our servers and mysql databases Now to fully migrate our mysql databases it is required that the following parameter is added in mysql my.cnf
innodb_page_size=64K (Default is 16k)

Now after adding we have to delete everything in data dictionary which is in /var/lib/mysql

and then run the following command
mysqld --initialize

These are the above steps we take to increase innodb_page_size of mysql. I just wanted to ask will i be able to do the above in mysql azure databases? I know i can do that in a linux VM but i want to do it databases provided by azure.

Azure Database for MySQL
Azure Database for MySQL
An Azure managed MySQL database service for app development and deployment.
747 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Navtej Singh Saini 4,221 Reputation points Microsoft Employee

    @Abdul Hayee

    Our team has conveyed:

    The innodb_page_size is read_only server parameter in Azure Database for MySQL Single Server and Azure Database for MySQL Flexible Server and cannot be changed because innodb_page_size can only be configured prior to initializing the MySQL instance and cannot be changed afterward.

    Please convey your use case on why you want to update this server parameter? As conveyed by the team,,migration should not be a problem if this parameter value is different but we would still advise to create test environment and check that.

    Navtej S

  2. Navtej Singh Saini 4,221 Reputation points Microsoft Employee

    @Abdul Hayee

    Here is the response from our Product Team regarding this:

    "This issue is documented here and please find the response below:
    Error: Row size too large (> 8126). Changing some columns to TEXT or BLOB may help. In current row format, BLOB prefix of 0 bytes is stored inline.
    Limitation: This error happens when you're migrating to Azure Database for MySQL using the InnoDB storage engine and any table row size is too large (>8126 bytes).
    Workaround: Update the schema of the table that has a row size greater than 8126 bytes. We don't recommend changing the strict mode because the data will be truncated. Changing the page_size isn't supported."

    Please let us know if any further issues.

    Navtej S