Server Essentials Access Anywhere - change RDP port

Jack Cheung 1 Reputation point

Hi. I've got 2016 Standard with the Essentials role added. I'd like to change the RDP port in use by the server to a custom port. When my users log in to Access Anywhere and they get a list of available RDP connections, will the custom port be reflected in the RDP file too? Thanks.

Windows Server 2016
Windows Server 2016
A Microsoft server operating system that supports enterprise-level management updated to data storage.
2,418 questions
Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,342 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. Carl Fan 6,836 Reputation points

    After you modify the registry to change RDP port.
    The next time you connect to this computer by using the Remote Desktop connection, you must type the new port. If you're using a firewall, make sure to configure your firewall to permit connections to the new port number.
    Restarting the Remote Desktop Service should be sufficient for the port change to become active. This will, however, terminate any active sessions. Just keep in mind that anyone using it will have to update their RDP file with :PORTNUMBER.
    Hope this helps and please help to accept as Answer if the response is useful.
    Best Regards,

    0 comments No comments

  2. Jack Cheung 1 Reputation point

    Hi. It sounds like you are talking about connecting to the Essentials server itself, but this isn't what I mean. When a user connects to Essentials via the web portal, they get a list of available internal PCs. When they click a PC, it downloads an RDP file. It is this RDP file which I want to have the custom port specified. Thanks.

    0 comments No comments

  3. Hugo Lyppens 1 Reputation point

    I have the same question.
    I ran dism /online /Enable-Feature:Gateway-UI to enable the RD Gateway settings on my Windows Server 2016 with essentials role. I can change the port number here. But then in the generated .rdp files for the hosts, this port is not reflected in the gatewayhostname field.

    0 comments No comments