CMG Failing to connect, azure instance failing to start.

Barleyologist 116 Reputation points
2021-02-26T01:54:43.607+00:00

Our CMG has been working and recently clients were not able to connect.
Looking at the SMS_CLOUD_PROXYCONNECTOR.log I see [ERROR: Failed to build Http connection 7ed67d18-fd3c-b802-4636-08b96683baac with server CMG.CLOUDAPP.NET:443]

Logged on to [https://portal.azure.com/] go to cloud service and see [Failed starting role Role could not be started. System is initializing.] I restarted the service and same error. Not sure what to do at this point.

Microsoft Configuration Manager
{count} votes

5 answers

Sort by: Most helpful
  1. Fiona Yan-MSFT 2,296 Reputation points
    2021-03-01T05:59:26.683+00:00

    @Barleyologist

    Thank you for posting in Microsoft Q&A forum.

    Based on my research, we could also check the cloudmgr.log on server side to track the CMG status.

    Besides, did you try the connection analyzer on SCCM console for CMG?
    72807-image.png
    Here is an excellent blog may for you to refer to:
    https://ronnydejong.com/2018/07/20/troubleshooting-cloud-management-gateway-quick-effectively-w-cmg-connector-analyzer/
    Note: This is non-official Microsoft article just for your reference.

    Have a good day!


    If the response is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    No comments

  2. Barleyologist 116 Reputation points
    2021-03-01T21:31:14.52+00:00

    @Fiona Yan-MSFT
    thanks for the reply.

    • CloudMgr.log is not showing any errors.
    • Connection Analyzer, I ran that first and that what got me to the Azure problem. Below are the result from the CA.
      • [Green] CMG in ready state
      • [Red] Connect to the CMG service to see if it's running
      • [Red] Check configuration setting of the CMG service is up to date
      • [Yellow] Check connection status of CMG connection points
      • [Green] Check CMG enabled site systems roles
      • [Red] testing the CMG channel for management point
    • Still looking at the article but not seeing anything that describes my problem.

  3. Barleyologist 116 Reputation points
    2021-03-03T21:00:27.617+00:00

    @Fiona Yan-MSFT Thanks again. I did not find anything notable in the SmsadminUI.log. Our CMG has been working for a year now and the referenced case looked to be a CNAME issue. I am using a self signed cert from our Enterprise CA for CMGurl.cloudapp.net and not a public cert for CMGurl.ourdomain.com so not sure how the CNAME would effect our situation. This is what I am seeing in the Azure portal73929-capture.png


  4. Zer0 1 Reputation point
    2021-03-25T20:36:37.207+00:00

    What was the resolution?

    No comments

  5. Rahul Jindal [MVP] 6,246 Reputation points Microsoft MVP
    2021-03-26T07:23:07.057+00:00

    Is port 443 being used for anything else? Where is your cmg proxy connector installed?

    No comments