Suddenly .. Client with IP address '20.76.4.235' is not allowed to access the server. When running Pipeline with Stored Procedure Activity in Region West Europe

Robin Smits 131 Reputation points
2021-02-26T12:29:31.387+00:00

We have an Azure Data Factory running in Region West Europe. On a regular basis we trigger some Pipelines which contain Stored Procedure Activities to trigger SP's in an Azure SQL database which is in the same region.

All worked well for the last few months but since today we are getting the following error:
"Client with IP address '20.76.4.235' is not allowed to access the server."

Which is weird because that is one of the IP adresses registered to Microsoft.

The Stored Procedure Activity is configured with a Linked Service and Managed Private Endpoint to approach the Azure SQL service. Test Connection on the service works just fine...and also other activities work.
This should just work...it did at least until yesterday.

There are no known Service Interruptions reported on the Microsoft Azure site.
Is someone else also experiencing similar issues? Or any guidelines on how to troubleshoot?

I could add as a work around the Microsoft IP adress on the firewall list for the Azure SQL database....but the whole point of the Linked Services and endpoints is that you don't have to.

Azure Data Factory
Azure Data Factory
An Azure service for ingesting, preparing, and transforming data at scale.
9,942 questions
{count} vote

Accepted answer
  1. KranthiPakala-MSFT 46,432 Reputation points Microsoft Employee
    2021-03-02T02:51:40.703+00:00

    Hi Hi @Robin Smits ,

    Thanks for your response and additional details. As this look like a firewall issue, below are 2 recommendations

    1. Please try whitelisting latest Azure Integration Runtime IP addresses : https://learn.microsoft.com/azure/data-factory/azure-integration-runtime-ip-addresses#azure-integration-runtime-ip-addresses-specific-regions As called out in this document, the list of service tags together with IP address range details are updated and published weekly. This could be the reason you are seeing the error. 73252-image.png
    2. The better option is to Allow Azure services and resources to access the SQL server 71994-image.png

    Hope this helps. Let us know how it goes.


    Thank you
    Please do consider to click on "Accept Answer" and "Upvote" on the post that helps you, as it can be beneficial to other community members.


0 additional answers

Sort by: Most helpful