Android Webview not rendering the headers of Sharepoint page

Aravindh 1 Reputation point
2021-02-26T10:52:57.64+00:00

I have an Android WebView where I want to show a sharepoint page, but certain elements of the page are not showing up. But the same Sharepoint page is rendering perfectly fine in mobile web browser. Find the attached image for reference

I have an Android WebView where I want to show a page, but certain elements of the page are not showing up.

Since its a work related page and you need an account to access it but its hosted in Microsoft Sharepoint.

On picture 1 (right) is my WebView that is not displaying the 2 header bars that can be seen on the picture 2 (left) and also in the middle there is a floating button that goes over the views, which is also not displayed in Android's WebView. Picutre 1 is the page in a normal web browser but in the mobile view. I also tried opening the page normally via phone's browser and it also worked fine.72408-webview.png

SharePoint
SharePoint
A group of Microsoft Products and technologies used for sharing and managing content, knowledge, and applications.
10,073 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. ChelseaWu-MSFT 6,316 Reputation points
    2021-03-01T01:04:31.447+00:00

    Hi @Aravindh , thanks for posting in the Q&A forum.

    SharePoint Mobile App does not render page the modern home page same as in browser view.
    The Office365 Suite Bar will hide in SharePoint mobile app, which is the default behavior. And you will see only site name and other basic buttons like search, navigation and follow site on the header in the mobile app.

    72783-20210301-004224000-ios.jpg

    Note that this only applies to the modern home page, you can see different behaviors in a list/library, or other pages from the Page library.
    In addition, any customization you applied on the page will not render in the SharePoint mobile app.

    I would suggest you test in another site or on another device for confirmation.
    Also make sure you have updated to the latest version of SharePoint mobile app to begin with.


    If an Answer is helpful, please click "Accept Answer" and upvote it.
    **Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread. **