SQL Express 2019 - Can't remotely connect

Hugh O'Donnell 96 Reputation points
2021-02-26T21:09:15.44+00:00

I have a fresh Windows Server 2019 with a fresh copy of SQL Server 2019 Express. Windows Firewall is turned off.

I installed under default (not named) instance, and have no problems connecting locally with SSMS 2019. However, I can't remotely connect in any way. I don't believe it is listening on any ports.

I've ran netstat -an, and port 1433 is nowhere to be found.

The server is x64 and I would think the install is x64, but I don't have the "SQL Server Network Configuration" tab in Sql Server Configuration Manager, but the (32bit) ones:
72602-image.png

I've looked in the SQL Server Logs for "listening" and nothing is found.

I've tried telnet'ing from the installed machine to 127.0.0.1 1433 as well as 10.1.1.5 1433 and neither work.

To me, it seems like even though TCP/IP is Enabled on port 1433, it is not working. But, once again, that is under the (32bit) node.

Oh, and I don't have an "IP Addresses" tab when I go to properties on Client Protocols... TCP/IP.

I'm absolutely stumped. Any ideas?

SQL Server
SQL Server
A family of Microsoft relational database management and analysis systems for e-commerce, line-of-business, and data warehousing solutions.
13,045 questions
{count} votes

Accepted answer
  1. Hugh O'Donnell 96 Reputation points
    2021-03-01T20:02:32.177+00:00

    Thank you to all of you who attempted to help. I was able to get it with just changing the value for the TCP protocol / Enabled in the registry from 0 to 1 and then restarting the service.
    73096-image.png

    I still don't know my Configuration Manager won't show the 64bit nodes. I even uninstalled all of SQL's programs, deleted both the 32bit and 64bit folders of SQL Server under Program Files, and reinstalled.

    The path for the Configuration Manager I am using is: C:\Windows\SysWOW64\mmc.exe /32 C:\Windows\SysWOW64\SQLServerManager15.msc

    It is the only SQLServerManager*.msc I have on my entire machine.

    I normally like finding the REASON for something and not just a registry hack. But, in this case, I think I will just move on.

    Thank you once again for all that supplied wisdom and help!


6 additional answers

Sort by: Most helpful
  1. David Browne - msft 3,771 Reputation points
    2021-02-26T21:21:44.767+00:00

    Run mmc.exe and add-remove Snap-In to find the correct SQL Server configuration Manager. You may have a couple versions installed.

    Eg here's mine:

    72555-image.png

    0 comments No comments

  2. Hugh O'Donnell 96 Reputation points
    2021-02-26T21:30:04.717+00:00

    Thank you. However, I only have one listed, and it shows the same nodes (none of the 64 bit ones).


  3. tibor_karaszi@hotmail.com 4,306 Reputation points
    2021-02-27T17:00:32.583+00:00

    Look at your screenshot closely. You are in the wrong place! You are configuring what netlib this machine will try to connect with as a client machine. You are not configuring your Express SQL server instance!

    You need to find a proper SQL Server Configuration Manager tool and use that tool to configure the right thing. If that fails, then just modify the registry directly (go to a machine that is working and pick up the registry entries from there). One thing you can try is the Computer Manegement tool and see if you find the proper MMC in there (Under Services and Applications). If you can't find the right SQL Server Configuration Manager from there either, then you might not want to spend too much time on this machine considering the installation is apparently not healthy.


  4. AmeliaGu-MSFT 13,961 Reputation points Microsoft Vendor
    2021-03-01T06:18:23.94+00:00

    Hi HughODonnell-7007,

    The loss of SQL Network Configuration 64bit may be caused by the sqlmgmprovider.dll file is broken or missed. Please go to \Program Files\Microsoft SQL Server\150\Shared to see if the sqlmgmprovider.dll is missed. If it is not there, you can copy one from another machine, or re-install SQL Server. Please refer to SQL Network Configuration 64bit is missing in SSCM which might help.
    If the solution above does not work, please take a look at this article which might help.
    In addition, please go to Registry Editor -> check if Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL15.MSSQLSERVER\MSSQLServer\SuperSocketNetLib\Tcp registry key exists.
    72730-01.jpg

    Best Regards,
    Amelia


    If the answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments