How to redirect a IP to a DNS name

Micael Felix 1 Reputation point

How to redirect a public ip to a dns name?

i'm hosting a public game server but the players need to conect via public ip.
i'm trying to put a dns to resolve this ip.


a player need to conect to server, that player needs to type the entire public ipv4 and click in conect like:

i want to redirect that ip to a dns in azure like:

Azure DNS
Azure DNS
An Azure service that enables hosting Domain Name System (DNS) domains in Azure.
634 questions
{count} votes

3 answers

Sort by: Most helpful
  1. Micael Felix 1 Reputation point


    0 comments No comments

  2. SUNOJ KUMAR YELURU 14,016 Reputation points MVP

    Hi @Micael Felix
    Check on the below url it may help on your issue.
    Tutorial: Map an existing custom DNS name to Custom domain name
    Changing your DNS settings to point to a different IP address

    If the Answer is helpful, please click Accept Answer and up-vote, this can be beneficial to other community members.

    0 comments No comments

  3. GitaraniSharma-MSFT 49,401 Reputation points Microsoft Employee

    Hello @Micael Felix ,

    Azure-created DNS suffix cannot be modified.
    Please refer :

    If you want to add your own custom domain for an Azure service, you could add a CNAME type DNS record like CNAME or A type record like A your Azure public IP address in your DNS domain provider.

    You also could select to host your domain in Azure DNS, then you can manage your DNS records on Azure portal. In order to use Azure DNS for your custom domain, you must first delegate your domain to Azure DNS. Once your domain is delegated to your Azure DNS zone, you are able to configure the DNS records needed.
    Delegate a domain to Azure DNS :
    Use Azure DNS to provide custom domain settings for an Azure service :

    Kindly let us know if the above helps or you need further assistance on this issue.


    Please "Accept the answer" if the information helped you. This will help us and others in the community as well.

    0 comments No comments