Storage Spaces VirtualDisk showing as RAW

Doni 1 Reputation point
2020-05-24T01:22:08.587+00:00

I have 8 disks in a Storage Spaces pool with a single virtual disk carved out of it. I recently re-installed the OS which WAS Server 2012 R2 but am now using Windows 10 Education edition with all the latest updates installed.

After the initial OS install, Windows 10 picked up the Storage Spaces pool no problem. I was even able to pull backed up files from it to restore some applications. I enabled features such as Hyper-V and others and rebooted several times. The virtual disk (mine is assigned to "S:") came back just fine every time.

I "upgraded pool" because it was an option and I didn't plan on going back to an older version OS. That seemed to go OK and I could still access the VD at this time.

Then I installed all the latest updates and rebooted. This is where my issue started.

I am no longer able to access the VD (my "S:" drive) though Manage Storage Spaces reports that the VD is OK. Checking the health through PowerShell also reports that health is OK.

Disk Manager thinks that the VD is in "RAW":

a2xzdjf.png

and not NTFS which is what it should say. CHKDSK knows it's in NTFS because it reports it as such when I run it.

This is what I get when I attempt to access the VD through Windows Explorer:

WQeGU7U.png

I click cancel on that, fearing I may lose data (if I haven't already) then I get this:

wrVZhPb.png

I have tried:

  • Running
    chkdsk
  • Fixed a ton of errors but didn't seem to help
  • Running
    Connect-VirtualDisk
  • doesn't seem to help

I've looked through the Event Viewer but don't see anything useful there but I may not be looking in the correct place.

If I can't get this to work I stand to lose ~12 TB of data.

I can't find tags for this but there should probably be:

storage-spaces, windows-10-education

I'm just going to add a tag that's close even though it's not quite right.

EDIT: I've purchased R-STUDIO and I can see all of my files still sitting there. I'm even able to pull them back to the "C" drive. I just ordered an external drive large enough for me to extract them to that before blowing this VD away unless I can figure out how to bring it back.

Windows 10 Setup
Windows 10 Setup
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Setup: The procedures involved in preparing a software program or application to operate within a computer or mobile device.
1,919 questions
{count} votes

5 answers

Sort by: Most helpful
  1. Anonymous
    2020-05-24T03:48:09.083+00:00

    May want to ask this one over here.

    https://serverfault.com/questions/tagged/storage-spaces-direct

    or here (not all windows 10 forums have migrated)

    https://social.technet.microsoft.com/Forums/en-US/home?forum=win10itprogeneral

    --please don't forget to Accept as answer if the reply is helpful--


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    0 comments No comments

  2. Don Cuthbert 411 Reputation points
    2020-05-24T04:03:42.657+00:00

    Try booting from the same version of Windows 10 install media that was last working with the Pool. Do not assume that the RAW status is permanent. It may be that only older versions of Windows (such as Server 2012 R2) can no longer read the Pool volume.

    Once you have booted the install media, use SHIFT-F10 to get a command prompt and find your Pool volume. See if your files are all intact.

    This has happened to me before also.

    0 comments No comments

  3. Doni 1 Reputation point
    2020-05-24T04:06:32.343+00:00

    I've tried re-installing Windows 10 Education (which WAS working) to no avail. I'm starting to think it was that "upgrade pool" option that broke me.

    I purchased some file recovery software and I can see that my files are intact... I just can't get to them. I could restore them to other media (I just ordered a drive that will hold it all to go this route if I have to) but I'd much rather just fix this VD.

    0 comments No comments

  4. Don Cuthbert 411 Reputation points
    2020-05-24T04:43:30.46+00:00

    I recently lost about 3 TB of files in a similar manner. My loss was caused by upgrading the Pool to match the Insider version of Windows 10 that I was running. All was fine until I booted with an older version of Windows 10 install media. I knew the Pool volume would appear RAW from the earlier version, but this time, mounting it from the old Windows version destroyed it entirely. I could no longer access it from the Insider Version at all.

    I did manage to rescue some files, but because of the multiple copies on the various Pool disks, I ended up with poor copies of many photos and videos and multiple copies. I still have not really sorted through it all to see what I can salvage. I just copied all that I could to other disks, using some very slow rescue software.

    0 comments No comments

  5. Don Cuthbert 411 Reputation points
    2020-05-24T05:05:58.347+00:00

    It may be worth asking Microsoft to help to recover your data. They may have some means to help.

    0 comments No comments