WSL version 1 - npm fails to install a package

Martin Kostadinov 36 Reputation points
2021-02-27T15:22:00.16+00:00

I'm trying to start the DataTurks project locally on my WSL (https://github.com/DataTurks/DataTurks/) but I ran into some npm problems which I believe is linked to the WSL. I use WSL v1 and when I try to install the packages via npm install, it goes well until it hits the grpc library and crashes, as it logs the error as "EACCES: permission denied, rename '/home/kmartin62/DataTurks/bazaar/node_modules/.staging/grpc-2c7a1feb/node_modules/mkdirp' -> '/home/kmartin62/DataTurks/bazaar/node_modules/.staging/mkdirp-97188a16". I tried to run it with sudo infront but the error keeps flashing and it prevents me from installing the base packages. Does anyone know how to solve this or ever experienced something like this?

Not Monitored
Not Monitored
Tag not monitored by Microsoft.
37,059 questions
0 comments No comments
{count} votes

Accepted answer
  1. Leon Laude 85,701 Reputation points
    2021-02-27T15:23:28.273+00:00

    Hi @Martin Kostadinov ,

    Please note that WSL is currently not supported in the Q&A forums, the supported products are listed over here https://learn.microsoft.com/en-us/answers/products.

    I suggest creating an issue over here:
    https://github.com/MicrosoftDocs/WSL/issues

    ----------

    (If the reply was helpful please don't forget to upvote and/or accept as answer, thank you)

    Best regards,
    Leon

    1 person found this answer helpful.
    0 comments No comments

0 additional answers

Sort by: Most helpful