Installing ghostscript within Windows container is failing

Avinash Modi 21 Reputation points
2021-02-27T14:13:58.88+00:00

I am using below dockerfile content to install ghostscript within my windows container

FROM mcr.microsoft.com/windows/servercore:ltsc2019

ADD https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs952/gs952w64.exe . 

RUN C:\gs952w64.exe /S /NCRC

CMD ["cmd.exe"]

But this is failing with following error:

The command 'cmd /S /C C:\tmp\gs952w64.exe /S /NCRC' returned a
non-zero code: 3221225785

I am able to do silent installation of ghostscript with this command in my local machine: C:\gs952w64.exe /S /NCRC
but not sure why it is failing in container.

I tried shared solution from here: https://stackoverflow.com/questions/62389316/installing-ghostscript-in-docker-windows-image-returned-a-non-zero-code-1
but I got same error here as well.

Chocolatey installed 2/3 packages. 1 packages failed. See the log for
details (C:\ProgramData\chocolatey\logs\chocolatey.log).

Failures

  • ghostscript.app (exited -1073741511) - Error while running 'C:\ProgramData\chocolatey\lib\Ghostscript.app\tools\ChocolateyInstall.ps1'.
    See log for details. The command 'cmd /S /C choco install --yes
    ghostscript --version=9.52 ;' returned a non-zero code: 3221225785

Can anyone help me on this?

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,414 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Candy Luo 12,681 Reputation points Microsoft Vendor
    2021-03-01T07:42:07+00:00

    Hi ,

    Our forum mainly focus on container cannot start or pulling container image related issue. For how to install Ghostscript in windows container, this is beyond our forum support range.

    Let's appreciate that the other members in our forum can share their experience with us about this scenario.

    Best Regards,

    Candy

    --------------------------------------------------------------

    If the Answer is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments