VM size suddenly not available in current availability zone

j b 21 Reputation points

I've been running a basic Win10 VM (F4s_v2) in US West 2 Availability Zone 1 for a few short weeks. Everything has gone swimmingly until this morning, when it failed to start. I have the VM automatically shutting down at 2AM and restarting (via a Powershell script) at 8AM. It did not start this morning, so I tried to manually restart. It threw the following error:

Failed to start virtual machine 'DNSR'. Error: The requested VM size 'Standard_F4s_v2' is not available in the current availability zone. The sizes available in the current availability zone are: .

I tried to move all of the related resources to US Central. Everything could successfully move except the VM. I tried to resize the VM, but that failed as well. Any ideas on how else to approach this?

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
5,278 questions
{count} votes

Accepted answer
  1. shiva patpi 10,251 Reputation points Microsoft Employee

    Hello @j b ,
    Thanks for your query , I just tried deploying f4sv2 in USWest2 Zone 1 which went through successfully. Probably it might be a temporary issue at that particular time.
    Can you try to resize again ?

    FYI - When you come across similar issue you can always try to resize to some other available SKU .

    If the above information helps , kindly "Upvote and Accept the Answer"

    1 person found this answer helpful.
    0 comments No comments

0 additional answers

Sort by: Most helpful