After upgrade to VS Studio 2019 v16.8.6 unable to Add New Report ... "Member not found. (Exception from HRESULT: 0x80020003 (DISP_E_MEMBERNOTFOUND))

DJAdan 671 Reputation points
2021-03-01T17:37:56.71+00:00

Hi All, R

Recently I upgraded Visual Studio 2019 v16.8.6. Since then, I have been getting the error:

73135-image.png

73095-image.png

I am able to work around this problem by either copying an existing report, or using the Wizard, but this is annoying. I have reviewed earlier posts regarding this problem, but some are quite old. Before the upgrade, I had no problems. Is there a fix available?

Thanks!
--Dan

SQL Server Reporting Services
SQL Server Reporting Services
A SQL Server technology that supports the creation, management, and delivery of both traditional, paper-oriented reports and interactive, web-based reports.
2,849 questions
0 comments No comments
{count} votes

Accepted answer
  1. ZoeHui-MSFT 34,581 Reputation points
    2021-03-02T01:56:47.633+00:00

    Hi @DJAdan ,

    Some users have encountered this issue recently in VS Studio 2019.

    A temporarily workaround is that you may add a existing rdl report to modify.

    Please also report the problem like this, the product team will help to deal with the issue.

    Your feedback enables Microsoft to offer the best software and deliver superior services.

    Regards,
    Zoe


    If the answer is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    What can I do if my transaction log is full?--- Hot issues November

    How to convert Profiler trace into a SQL Server table -- Hot issues November


4 additional answers

Sort by: Most helpful
  1. Michael Taylor 50,026 Reputation points
    2021-03-01T18:42:30.647+00:00

    A report such as from the SQL Server Reporting Services extension? If that is so then you should report it to the extension writers as they'll have to fix it. However I'm running 16.8.6 of VS along with the latest version of the extension (15.0.19124.0) and I can create reports just fine. They will likely need to see the error details and potentially the logs to identify what is going wrong.

    0 comments No comments

  2. DJAdan 671 Reputation points
    2021-03-01T18:59:55.367+00:00

    Hi cooldadtx,

    THanks for responding ...

    The SQL Server reporting Services extension is provided by Microsoft. I also have SQL Server Data tools installed.

    The problem only rears it's head if I "Add New Item ..." . Otherwise, everything works fine.

    --Dan


  3. DJAdan 671 Reputation points
    2021-03-05T13:11:13.18+00:00

    Although the issue still exists, I have acceptable workarounds.

    The fact that other users have reported this issue to Microsoft is sufficient for me to believe that it will be addressed in a subsequent release.

    Thank you.

    --Dan

    0 comments No comments

  4. DJAdan 671 Reputation points
    2021-03-12T22:00:09.283+00:00

    Hi All,

    I have an update to this issue ... I just upgraded Visual Studio to 16.9.1 -- and the problem is solved.

    I can now Add New Report without error.

    Thanks again.

    --Dan

    0 comments No comments