code outlining not always working in SSMS 18.8

Martin Nielsen 1 Reputation point
2021-03-02T08:41:23.497+00:00

code outlining stops working in SSMS 18.8 (and all previous 18.x versions I have tried) when I open the program it works fine in the beginning, but then after a while it suddenly stops working. What I have discovered so far is that there may be a problem if some object have special names, specifically I found that the following piece of code would make outlining disappear for the entire file: SELECT ....... S.End .... FROM ..... I know end is a reserved word but i'm surprised that it ruins outlining for the whole file, especially since SSMS 17.x handles this like a pro I tried adding brackets, which did not help until after I commented the offending line out and back in there may be other examples like this, but this is the first where I was able to pinpoint the reason for the problem

SQL Server
SQL Server
A family of Microsoft relational database management and analysis systems for e-commerce, line-of-business, and data warehousing solutions.
13,117 questions
{count} votes