Cannot deploy Word & Powepoint 2016 templates through GPO

AlexandeR TheGreaT 116 Reputation points
2021-03-02T10:04:56.917+00:00

I have created 2 folders in a storage partition of a file server(2016) which include word and powerpoint custom templates and I need them to be deployed in the desktop apps of the users but it's not working.

I have already copied ADMX/ADML files in C:\WindowsPolicy\Definitions and C:\WindowsPolicy\Definitions\EN-US folders in the DC.

Then created the GPOs and applied them to the specific groups that I created for this reason.

  • For the word template GPO I changed "User Configuration\Policies\Microsoft Office 2016\Shared Paths\Enterprise Templates Path"(also tried User Templates Path & Workgroup Templates Path) to the location where the template files are in File Server.
  • For the powerpoint template GPO I changed "User Configuration\Policies\Microsoft Office 2016\Shared Paths\Enterprise Templates Path"(also tried User Templates Path & Workgroup Templates Path) to the location where the template files are in File Server.

What am I missing here?

Office Management
Office Management
Office: A suite of Microsoft productivity software that supports common business tasks, including word processing, email, presentations, and data management and analysis.Management: The act or process of organizing, handling, directing or controlling something.
2,046 questions
0 comments No comments
{count} votes

Accepted answer
  1. AlexandeR TheGreaT 116 Reputation points
    2021-03-19T14:47:36.82+00:00

    As for the powerpoint issue I noticed that I had forgotten to relink the gpo. Now it is ok.

    UPDATE:

    It's now working.

    What I did is that I created a file preference, on top of the other one, which deletes the files included in the folder.

    Then they are recreated in the folder by the next preference.

    So, is a way to avoid the deletion and recreation of the files?


2 additional answers

Sort by: Most helpful
  1. DonPick 1,261 Reputation points
    2021-03-02T11:12:24.283+00:00

    we have successfully used 'Workgroup Templates' settings for Word/Powerpoint for many years (since Office95) which continues to work now with M365/2019.

    The settings deliver a simple registry key/value containing the servername\sharename.
    This is a single/common setting, apply/link it to all users that you want to consume the setting

    https://admx.help/?Category=Office2016&Policy=office16.Office.Microsoft.Policies.Windows::L_Workgrouptemplatespath

    this will add another folder into the backstage template picker


  2. AlexandeR TheGreaT 116 Reputation points
    2021-03-18T14:45:41.513+00:00

    After several days trying to deploy the templates, I finally did it with another method.

    I followed this guide:
    https://www.linkedin.com/pulse/how-deploy-office-word-template-via-gpo-group-policy-windows-poljic/

    I made the registry changes in user config so I didn't have to use loopback processing or computer configuration at all.

    I also created 2 items for each configuration because there are both English and Greek office installations in the company and the configuration in English could not copy the files to the directory written i Greek.

    So now I have 2 GPO, one for word and one for powerpoint but now I encountered another issue:

    Powerpoint app does not retrieve the template files as word app does.
    Default personal templates location is empty in powerpoint options whereas it is set by default in word options.

    79286-powerpoint-path.png 79253-word-path.png

    Furthermore, I can see the reg key for word but not for powerpoint.

    79186-powerpoint-reg.png 79225-word-reg.png

    Why is this happening?

    Second issue I also encountered is that when I delete a file from the source location and the run gpudate, the file is not deleted from the destination, too.

    I changed action from "update" to "replace" but nothing changed, the file was still in destination.

    79302-files-gpo.png

    79722-reg-gpo.png

    I don't understand what is wrong here.

    0 comments No comments