Remove whitepace in table row of SSRS report

MDuBose 716 Reputation points
2021-03-02T15:37:25.32+00:00

Hello,

I've created an SSRS report in Visual Studio. In my report, I'm experiencing spacing issues within the table cells. Image is below.

73471-screenshot.png

This table displays counts on a column per date. For 01/04/2021, there's whitespace in which I need to remove. In the design, I've tried modifying the height and padding of the Textbox in the Table. Also, I've tried setting the CanGrow and CanShrink property to False of the Textbox in the Table. In addition, when I export my report to PDF, there's blank pages in between each page. To fix this, I've tried, changing the report layout to Landscape then A4. I've also tried setting the report property called ConsumeContainerWhitespace to True.

Is there anyway I can remove the whitespace and remove the blank pages in between the PDF?

Update:

I also want to mention that in my table, the three columns are grouped and there is a hidden group as well which I can't delete.

SQL Server Reporting Services
SQL Server Reporting Services
A SQL Server technology that supports the creation, management, and delivery of both traditional, paper-oriented reports and interactive, web-based reports.
2,853 questions
0 comments No comments
{count} votes

Accepted answer
  1. MDuBose 716 Reputation points
    2021-03-09T15:16:07.377+00:00

    I've resolved the issue with the blank pages in the PDF by fitting my tables and textboxes in the default body width and height as much as possible. Also, changing the report layout to Landscape. As far as the extra whitespace in the table cell, that still exists, however, it doesn't seem to pose an issue with the layout.

    0 comments No comments

1 additional answer

Sort by: Most helpful
  1. Joyzhao-MSFT 15,571 Reputation points
    2021-03-03T03:04:36.257+00:00

    Hi @MDuBose ,

    • Set the ConsumeContainerWhitespace property of the report to True.
    • Set the body content to fit enough for the Report Page Width. Consider the margins too. Body width + Left and Right margins needs to be less than the report page width. Otherwise there will be blank spaces while exporting to PDF.
    • Remove unwanted space between the tables or charts in the report.
    • Check the page breaks, and disable those if there are no data by checking the Count of the data set.
    • Set the page breaks if you are setting the visibility of a particular section by using a parameter, by applying the same condition for the Disable property.

    If those things were done properly, there will not be any unwanted white spaces or empty pages in the report.

    Best Regards,
    Joy


    If the answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments