No recording device on Azure Virtual server

Mike Fairley 31 Reputation points
2020-05-27T00:47:42.597+00:00

Need recording on my Azure virtual server.
Sound is working fine.
No recording devices detected.

8667-annotation-2020-05-27-104605.png
Anyone help please?

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
7,514 questions
0 comments No comments
{count} votes

5 answers

Sort by: Most helpful
  1. KarishmaTiwari-MSFT 18,852 Reputation points Microsoft Employee
    2020-06-27T00:06:05.107+00:00

    Sorry for the delay on this. Can you please share which Azure VM are you using?

    Please take a look at the steps suggested in this Tech Community post and let me know if it resolves your issue: https://techcommunity.microsoft.com/t5/compute/audio-device-not-available-on-ms-azure-vm/m-p/67770

    Thanks

    0 comments No comments

  2. Mike Fairley 31 Reputation points
    2020-06-27T08:25:23.517+00:00

    That link did not help. It was explaining how to get audio and audio passthrough to the host.

    I have audio. That's not the problem. I need a recording device.

    0 comments No comments

  3. Ronen Ariely 15,101 Reputation points
    2020-06-28T14:26:39.227+00:00

    Good day Mike - @mikefairley-0522

    As you already understood, in order to use mic, you need a recording devices. When you are using remote desktop then you need a logical (you do not use physical device) device, which is basically an application which you install on your remote machine. In addition You need to transmit the sound from the local machine to a remote machine.

    Part one is in the remote machine, and part two is on your local machine (part two is what @karishmatiwari-msft spoke about).

    If you are using windows 10 as your remote machine, then you have a built-in logical device named "Remote Audio". We need to enable this device.

    On your remote machine: Choose Start, choose Run, enter regedit, choose the OK button, and then set the value of the following registry key to 0.

    HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp\fDisableAudioCapture

    ![10827-f.png]

    https://learn.microsoft.com/en-us/azure/devops/project/feedback/enable-remote-audio-capture?view=azure-devops

    0 comments No comments

  4. Mike Fairley 31 Reputation points
    2020-06-28T14:31:16.073+00:00

    The key already has a value of 0 on the remote device.


  5. Mike Fairley 31 Reputation points
    2020-06-28T23:00:08.873+00:00

    Windows 10 is connecting to a Windows Server 2019 Datacentre VM hosted on Azure

    0 comments No comments