Hybrid joined device shows Azure AD joined in AAD

KothawadeAjay-3456 11 Reputation points
2021-03-03T07:49:06.577+00:00

Hi all,

I am facing one issue with testing of Autopilot Hybrid AAD Joined scenario and need some help to understand this.
After enrolling the device with AAD account, it successfully creates a computer account in AD and AAD.
But in Azure AD it shows AAD registered instead of Hybrid AAD Joined.
73627-s1.jpg

Also on the client OS side when I run dsregcmd /status it shows AzureADJoined = No

73686-s2.jpg

On Event viewer I see this error.
73589-s3.jpg

Windows Autopilot
Windows Autopilot
A collection of Microsoft technologies used to set up and pre-configure new devices and to reset, repurpose, and recover devices.
424 questions
0 comments No comments
{count} vote

2 answers

Sort by: Most helpful
  1. Pa_D 1,071 Reputation points
    2021-03-03T22:54:06.977+00:00

    Check the following:

    1. are there any other PC completed Hybrid AAD join?
    2. Is your domain federared?
    3. Did you create a device OU and synced it using AD Connect?
    4. Have you completed AD Connect steps for Hybrid AAD join configuration?
    0 comments No comments

  2. Joseph PerryADM 21 Reputation points
    2021-09-02T19:23:04.097+00:00

    I'm facing the same issue. As a result, the AD groups the computer is a member of aren't synced to AAD.

    @Anonymous were you able to resolve this?
    Do you recall what the answer was?

    1) are there any other PC completed Hybrid AAD join? Yes, but none from autopilot.
    2) Is your domain federared? No
    3) Did you create a device OU and synced it using AD Connect? Yes
    4) Have you completed AD Connect steps for Hybrid AAD join configuration? Yes

    0 comments No comments