Remote Desktop timeouts and then remote machine has restarted

Christian Hansen 21 Reputation points
2021-03-03T09:45:32.93+00:00

I have a problem with working remotely. I have a machine sitting in my office, and I remote to it using a laptop I have at home.

I can remote to it fine, but usually after about an hour I get kicked out of the machine (citing timeout or no response to remote machine).

After a couple of minutes I remote to it again, and everything I had going on is no longer running (seems as though it has restarted).

I check update history, and it hasn't updated Windows. I look in the Event Viewer and I see:

73668-microsoftteams-image.png

Mind you, this does not happen when I work on-prem and use the machine directly, it only happens through remote work.

What can I do to fix this?

Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,335 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Grace HE 1,241 Reputation points
    2021-03-04T07:41:45.497+00:00

    Hi,

    Thank you for posting your query. With the issue description, here are some suggestions. And I would appreciate if you can help me with more information.

    1. what is the version of your session host and client machine?
    2. Using the quser command, you can view when a user RDP session was started, how long it was idle and the current session state.
      74149-image.png
    3. Please try to check and set the "Session Time Limits" policies
      If you use an RDS server, you can configure session timeout parameters in the RDS collection settings on the Session tab.
      74105-image.png You can also set the limits of an RDP session in the properties of a local (lusrmgr.msc) or domain user (dsa.msc — Active Directory Users and Computers).
      74130-image.png

    In Windows Server 2012 R2/2016/2019, you can set RDP session timeouts using Group Policies. You can do it either in the domain GPO editor (gpmc.msc) or in the Local Group Policy Editor (gpedit.msc) on an RDS server or client.
    Computer Configuration -> Policies -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Session Host -> Session Time Limits.
    74201-image.png

    In Windows Server 2008 R2, you could also set RDP session timeouts using a special console: tsconfig.msc (RD Session Host Configuration).
    74187-image.png

    --- if the suggestions above are helpful, please click ACCEPT ANSWER. Really appreciate. This will also help others with same issue to find this post quickly.---

    0 comments No comments