Cannot open web console HttpWebRequest_WebException_RemoteServer

Justin D 61 Reputation points
2021-03-03T17:26:51.55+00:00

This is a fresh install of Orchestrator 2019. I am running 3 servers total. 1 SQL server running SQL 2016, 1 server running the runbook service and the last server runs the remaining orchestrator services (web, mgmt and designer). I am using a domain service account to run the services. This account has sysadmin to the sql db and is local admin on all the orchestrator servers.
Finally got everything installed and the deployment manager shows the runbook and designer servers listed and all services are running without stopping.
When I open the web portal I am presented with 2 errors:
73839-image.png
73879-image.png

When I try to open the web service portal I am presented with a 403 error Forbidden error.
HTTP Error 403.14 - Forbidden
The Web server is configured to not list the contents of this directory.

I have been searching for a few days and I think the connection strings might be incorrect, but I am not sure. The connection string looks like it is trying to use a local sqlexpress db. I'm not sure if this is by design or not.
Any help is appreciated.

System Center Orchestrator
System Center Orchestrator
A family of System Center products that provide an automation platform for orchestrating and integrating both Microsoft and non-Microsoft IT tools.
218 questions
0 comments No comments
{count} votes

6 additional answers

Sort by: Most helpful
  1. Stefan Horz 3,466 Reputation points
    2021-03-04T09:28:26.763+00:00

    Hi @Justin D ,

    I can reproduce this.
    Turn off protected mode in IE. Add the FQDN (http://scowebserver.yourdomain.com) to "Local Intranet Sites" in IE. Restart IE und try to acccess http://scowebserver.yourdomain.com:82 again.

    Regards,
    Stefan

    1 person found this answer helpful.
    0 comments No comments

  2. Stefan Horz 3,466 Reputation points
    2021-03-03T20:57:35.81+00:00

    Hi @Justin D ,

    If you decrypt the Connection String with:

    C:\Windows\Microsoft.NET\Framework\v4.0.30319\aspnet_regiis.exe -pdf "connectionStrings" "C:\Program Files (x86)\Microsoft System Center\Orchestrator\Web Service\Orchestrator2012"

    it should look like:
    metadata=res:///Microsoft.SystemCenter.Orchestrator.WebService.ResourceModel.csdl|res:///Microsoft.SystemCenter.Orchestrator.WebService.ResourceModel.ssdl|res://*/Microsoft.SystemCenter.Orchestrator.WebService.ResourceModel.msl;provider=System.Data.SqlClient;provider connection string="Data Source=sholutionsvmsql\sc2019;Initial Catalog=Orchestrator;Integrated Security=True;MultipleActiveResultSets=True"

    73920-sql-connections-settings.png

    This Orchestrator DB is on the SQL Instance sholutionsvmsql\sc2019 and named Orchestrator.

    Check that the identity of the Application Pool "System Center 2012 Orchestrator Web Features" has access to this Database.

    73830-application-pool-identity.png

    What happens if you open: http://scoweb.yourdomian.de:81/orchestrator2012/orchestrator.svc/ ?

    73905-access-to-webservices.png

    Regards,
    Stefan

    0 comments No comments

  3. Justin D 61 Reputation points
    2021-03-03T21:34:20.2+00:00

    @Stefan Horz Thank you for your reply.
    It looks like the decrypted connection string doesn't have the data source portion as shown above. Can I manually add that in using what you have as an example or should I configure it elsewhere? I have validated that the service account does have access to the SQL database.

    73952-image.png

    This is what I see when I navigate to that virtual directory:
    73909-image.png

    Thank you again for your time and help on this. I appreciate it. Please let me know if you have any suggestions to resolve.

    0 comments No comments

  4. Stefan Horz 3,466 Reputation points
    2021-03-03T21:59:07.8+00:00

    @Justin D , I guess if you scroll down the connection string is ok, if you scroll down because the result of http://localhost:81/orchestrator2012/orchestrator.svc looks ok.

    Have you tried to open http://scowebserver.yourdomain.com:82 instead of http://locahost:82?

    0 comments No comments