VS 2019 After the latest update 16.9 Errors shown

ArtakTc 31 Reputation points
2021-03-04T02:13:17.377+00:00

Visual Studio 2019 has stopped working after update 16.9 was installed. I get errors such as "package did not load correctly". Does anyone else have this issue? I did tried many things such as re-installing but no matter what I did the issue still remains.

Visual Studio Setup
Visual Studio Setup
Visual Studio: A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.Setup: The procedures involved in preparing a software program or application to operate within a computer or mobile device.
1,010 questions
{count} votes

5 answers

Sort by: Most helpful
  1. ArtakTc 31 Reputation points
    2021-03-04T13:23:52.1+00:00

    When I run Visual Studio as administrator it works. When I run as a normal user error displayed in popup "The 'Environment Package Window Manager' package did not load correctly" and Visual Studio fails to open.

    2 people found this answer helpful.
    0 comments No comments

  2. Ben Tesch 41 Reputation points
    2021-03-05T03:24:45.923+00:00

    I have the same issue, and deleting the %localappdata%\Microsoft\VisualStudio\16.0_xxxx\ComponentModelCache folder doesn't help. Running as administrator does.

    1 person found this answer helpful.
    0 comments No comments

  3. Anna Xiu-MSFT 27,816 Reputation points Microsoft Vendor
    2021-03-05T13:34:50.24+00:00

    Hi @ArtakTc ,

    It has been reported to product team, you can view the similar issue: https://developercommunity.visualstudio.com/t/Error-The-Environment-Package-Window-M/1356392?space=8&q=Environment+Package+Window+Management+package+did+not+load+correctly+run+Visual+Studio+2019+as+administrator.

    You can also add your comments in there to track the process. If there is any update, I will also add it here.

    Thanks for your understanding.

    Sincerely,
    Anna

    • If the answer is helpful, please click "Accept Answer" and upvote it.
      Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

  4. WiseyD 1 Reputation point
    2021-03-12T00:16:18.067+00:00

    I'm having the same issue. Happened after update to 16.9.1

    0 comments No comments

  5. Artak Tchalgouchian 1 Reputation point
    2021-03-16T19:17:10.747+00:00

    latest update 16.9.2 fixes the issue. Thank you Microsoft!

    0 comments No comments