Visual Studio 2019 Community Fails to Launch

Ben Tesch 41 Reputation points
2021-03-05T03:13:32.23+00:00

I am attempting to install Visual Studio Community 2019 version 16.9.0. After installation, and upon launch, I encounter 5 separate dialogs stating "The '___' package did not load correctly." followed by a dialog that says "A problem occurred when loading the Microsoft Visual Studio menu." Most amusingly, the "Report a problem" button in the visual studio installer does not work.

I have attached screenshots of the various dialogs and the ActivityLog.xml file they refer to. One caveat: The dialog screenshots and ActivityLog.xml file came from different install attempts.

Things that did not work:

  1. More -> Repair in installer
  2. Uninstall and reinstall
  3. Deleting C:\Users\user\AppData\Local\Microsoft\VisualStudio\16.0_669f3657\ComponentModelCache
  4. Running C:\Program Files (x86)\Microsoft Visual Studio\Installer\resources\app\layout\InstallCleanup.exe -f as admin followed by reinstall
  5. Restarting my computer

All of this still happens even if I only attempt to install the core editor and no extra packages or anything!

74556-activitylog.xml74505-settings-package.png74557-common-ide-package.png74588-extensionmanagerpackage-package.png74488-environment-package-window-management-package.png74489-environment-package-window-management-package2.png74490-problem-occurred.png

Visual Studio Setup
Visual Studio Setup
Visual Studio: A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.Setup: The procedures involved in preparing a software program or application to operate within a computer or mobile device.
1,005 questions
0 comments No comments
{count} vote

Accepted answer
  1. Anna Xiu-MSFT 27,726 Reputation points Microsoft Vendor
    2021-03-05T13:02:28.11+00:00

    Hi @Ben Tesch ,

    Welcome to Microsoft Q&A!

    According to your error message, it has been reported here: https://developercommunity.visualstudio.com/t/Error-The-Environment-Package-Window-M/1356392?space=8&q=Environment+Package+Window+Management+package+did+not+load+correctly+run+Visual+Studio+2019+as+administrator.

    You can also add your comments in there to track the process, then we need to waiting for the response comes from the product team engineers. If there is any update, I will also add it here.

    Thanks for your understanding.

    Sincerely,
    Anna

    • If the answer is helpful, please click "Accept Answer" and upvote it.
      Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.
    1 person found this answer helpful.
    0 comments No comments

2 additional answers

Sort by: Most helpful
  1. Ben Tesch 41 Reputation points
    2021-03-05T03:19:55.347+00:00

    Visual Studio launches if I run as administrator. Fascinating.

    2 people found this answer helpful.

  2. John Ottone 0 Reputation points
    2023-06-23T10:37:13.6866667+00:00

    Xavier, can you make sure those packages you loaded from your other pc are registered in the GAC?

    0 comments No comments