How to allow Cygwin to run in Win10 for non-admin users

Eaven Huang 1,801 Reputation points

We've installed Cygwin software in our Windows 10 computers, but it was found that when our standard users run it, there is always error showing up as attached. I've googled around but didn't find a solution to tackle it. The ways I've tried:

  • Right-click the shortcut to allow all users to run it as administrator
  • Give full control on the folders there Cygwin resides
  • Edit registry key values on the software to give full control for the users
  • Grant "Power user" privilege for the standard users

None of above worked in the end. It works perfectly when using admin account but that's too risky for our environment. Any idea would be greatly appreciated!
P.S. I didn't get any luck finding any Cygwin support since this is open-source project, I also read from their webpage mentioning "All Windows environment variables are imported when Cygwin starts."


Windows 10 Security
Windows 10 Security
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Security: The precautions taken to guard against crime, attack, sabotage, espionage, or another threat.
2,324 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Ian Xue (Shanghai Wicresoft Co., Ltd.) 18,981 Reputation points Microsoft Vendor


    Give Runas a try. You may refer to the link below for more details.

    As this document suggests, you can ask Cygwin questions on Stack Exchange

    Best Regards,
    Ian Xue


    If the Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  2. MotoX80 25,656 Reputation points

    Did you look at the XWin.0.log file as the message says?

    Trace the program with Process Monitor.

    You will need to run it as an administrator. Be sure to stop the tracing as soon as you recreate the error. It can capture a lot of activity. Search for "Access denied" in the captured events.

    Or try a different X Windows server. I don't know how well it works, but here is one that I found.

    0 comments No comments