question

LPhngHin-7668 avatar image
1 Vote"
LPhngHin-7668 asked AnthonyNGOPLOTI-6226 published

Remote desktop connection: An internal error has occurred

Hi guys,

I have problem with RDP when connect to my Server (Windows 2016 std OS)

Some time, remote desktop faild with message: An internal error has occurred (please see more detail in video link)
- RDP client: Windows server 2016 or windows 10 pro
- Target: windows server 2016 std
- firewall off
- McAfee Enterprise antivirus unlocked all connection
Could you please help me to resolve this problem?

Regards,

Hien Le

Link video: https://youtu.be/BPirG4F8KhU





remote-desktop-services
· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi,
We are looking forward to your reply and ready for help.

--- if the suggestions above are helpful, please click ACCEPT ANSWER. Really appreciate. This will also help others with same issue to find this post quickly.---

0 Votes 0 ·

hi Please kindly fix for me ,


The issues is that : an internal error has occurred

0 Votes 0 ·
GraceHE-MSFT avatar image
2 Votes"
GraceHE-MSFT answered AnthonyNGOPLOTI-6226 published

Hi,
Thank you for your reply. Here are some suggested solutions.

  1. Change Remote Desktop Connection Settings
    Go to the Start Menu, search for Remote Desktop Connection, and open it up.
    Click on Show Options to unveil all the settings.
    Switch to the Experience tab and then make sure ‘Reconnect if the connection is dropped’ box is checked
    Try connecting again.

  2. Changing MTU Value
    To change your MTU value, you will have to download a tool called TCP Optimizer. You can download it from https://www.speedguide.net/downloads.php.
    Once downloaded, open up TCP Optimizer as an administrator.
    At the bottom, select Custom in front of Choose settings.
    Change the MTU value to 1458.
    Click Apply Changes and then exit the program.
    Check if it fixes the issue.

  3. Changing Security of RDP in Group Policy Editor
    Go to the Start Menu, search for Local Group Policy and open up ‘Edit group policy’.
    Navigate to the following directory:
    Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Security
    On the right-hand side, locate the ‘Require use of specific security layer for remote (RDP) connections’ and double-click it to edit it.
    If it is set to ‘Not configured’, select Enabled and then in front of Security Layer, choose RDP.
    Click Apply and then hit OK.
    Restart your system so that the changes take effect.
    Try connecting again.

  4. Disabling Network Level Authentication
    Go to your Desktop, right-click on This PC and select Properties.
    Click on Remote Settings.
    Under Remote Desktop, un-tick the ‘Allow connections only from computers running Remote Desktop with Network Level Authentication’ box.
    Click Apply and then hit OK.
    See if it isolates the issue.

---If the suggestions above are helpful, please ACCEPT ANSWER. Really appreciate. This will also help others with similar issue to find this post quickly. ---


· 10
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi Grace,

Thank you for the support!

The issue has been fixed after I turn off "receive side scaling" in the NIC Team config.

Regards,

Hien

76417-capture.png


2 Votes 2 ·
capture.png (187.6 KiB)

The only option that worked for me is option 4, which isn't ideal, but hey, at least it works now.

0 Votes 0 ·

This works for me, thank you!

0 Votes 0 ·

Option 3 is worked on most of the servers.

0 Votes 0 ·
DynamicsAdmin-4267 avatar image DynamicsAdmin-4267 YuvarajuVemalaSarasAmerica-1146 ·

Yes option 3 worked for me

0 Votes 0 ·

This one work for me guys.....

Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Security
On the right-hand side, locate the ‘Require use of specific security layer for remote (RDP) connections’ and double-click it to edit it.
If it is set to ‘Not configured’, select Enabled and then in front of Security Layer, choose RDP.
Click Apply and then hit OK.
Restart your system so that the changes take effect.
Try connecting again.

Regards,
Ashok

0 Votes 0 ·

Solution 3 worked for me. Thanks for the detailed troubleshooting guide.

0 Votes 0 ·

I would suggest trying number 3 first. It worked for me. It appeared to work but on retrying its back to multiple instances of An internal error has occurred before allowing the connection.

0 Votes 0 ·
Show more comments
GraceHE-MSFT avatar image
0 Votes"
GraceHE-MSFT answered LPhngHin-7668 commented

Hi,
Thank you for posting your query. According to your description above, I would appreciate if you can help me with more information. And here are some suggestions.

  1. please check your RDP version.
    74689-image.png

  2. When VPN'ed in from the computer in question, can you ping the remote network? If not then thats where the problem lies.
    If yes then can you ping any other device on the network. Is there any other server which you can try and connect to? does that work?

  3. reset the VPN tunnel and set it to allow all traffic.

  4. remove the PC from the domain and rejoined.

---If the suggestions above are helpful, please ACCEPT ANSWER. Really appreciate. This will also help others with similar issue to find this post quickly. ---







image.png (22.3 KiB)
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi Grace,

Thank you for your support!

I would like to answer your question as bellow:

1. RDP version:
RDP version:



2 & 3. No VPN connection is established
4. I tried to rejoin PC to the domain but still get same problem

Regards,

Hien







0 Votes 0 ·
image.png (18.3 KiB)
KoppNikolasexternal-7238 avatar image
0 Votes"
KoppNikolasexternal-7238 answered
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Neman avatar image
0 Votes"
Neman answered

Adding only for the record, as the problem could be at target computer rather than your source. Our problem was intermittent connection to an AWS EC2 instance which had been working fine for months. One user was logged in, but nobody else could connect. (RDP allows up to two simultaneous logins.) The solution was to confirm all users were logged out, reboot via the EC2 console, log in with an admin user, and forcibly disconnect all other interactive (i.e. supposedly human) users.

After reboot/login:
1. Open a command prompt (either as an admin user or an administrative command prompt)
2. Type qwinsta or query session (gives more info than query user) - see https://docs.microsoft.com/en-us/windows-server/administration/windows-commands/qwinsta
3. Look at ID (session ID) column in the list of users. Determine which ones should be logged off. (Your current user has an > preceding its name.)
4. Type logoff 3 to forcibly logoff the user with session ID = 3. No output appears, but the session is terminated. (Run qwinsta a second time to confirm.)

This error is too broad and captures too many possible problems with one message.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

NickolaiMcghie-7555 avatar image
2 Votes"
NickolaiMcghie-7555 answered Patrick1 commented

Denial of Service attacks on port 3389 (RDP) can also cause this issue. Just had to block request on a public webserver which had thousands of records revealing external entities attacking that port. After about 5 minutes of blocking external access to that port the internal network access worked.

· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Indeed, since none of the suggestions above worked for me, I took a look in the event viewer. It appeared there were thousands and thousands of failed login attempts. The event viewer won't show the external IPs, so I used a port monitor for that. It's very unfortunate that RDP does not offer a block after N failed attempts, though there are 3rd party programs that can do this for you. Eventually I got rid of the hack-attempts by changing the RDP port number in the registry.

//Daniel

0 Votes 0 ·

Yep, that was the issue for me too.
My solution was to adjust the inbound rules on my firewall to only allow the specific IP address of my client.

0 Votes 0 ·
SimonKravis-3338 avatar image
0 Votes"
SimonKravis-3338 answered

Not an answer but I often get the Internal Error message from RDP at various stages when accessing my VPS - sometimes before showing the login screen, sometimes after supplying credentials. If I try making the connection multiple times it usually works eventually.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.