Can't use Debugger invalid 'cwd' value {path to current project} The system cannot find the path specified.

Jorge Merino Santander 1 Reputation point
2021-03-05T04:33:21.39+00:00

I just installed Visual Studio because i wan to learn c# and .NET 5.0 so i created a full new project with the template of ASP .NET Core MVC but debugger won't start up and it sends a message.

invalid 'cwd' value {path to current project} The system cannot find the path specified.

It is a fresh install and a whole new project without touching any code.

i'm working on a MacBook Pro (15-inch, 2019) with macOS Big Sur v 11.2.2.

What have you tried to troubleshoot this?
I have tried to change the path location, reinstall Visual Studio, update any Framework, start the app in the terminal, create new projects but i always get the same errror.
When i run 'Start without debuging' it works.

Hope you can help me out of this. Thank you.
74605-screen-shot-2021-03-05-at-012644.png

74606-screen-shot-2021-03-05-at-012703.png

Not Monitored
Not Monitored
Tag not monitored by Microsoft.
37,755 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Tianyu Sun-MSFT 29,446 Reputation points Microsoft Vendor
    2021-03-08T03:37:31.473+00:00

    Hi @Jorge Merino Santander ,

    Thank you for taking time to post this issue in Microsoft Q&A forum.

    Since our forum(vs-general, vs-debugging) is about Visual Studio, and as you know, Visual Studio for Mac is different from Visual Studio, I suggest you post this issue in our Developer Community(Visual Studio for Mac).

    BTW, from the error message, it seems the error is related to the Path, perhaps you can check these aspects: Did you change some paths while installing VS for Mac? If you try to use default path will this issue disappear? Did the path mentioned from the error message exist?

    Best Regards,
    Tianyu

    • If the answer is helpful, please click "Accept Answer" and upvote it.
      Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.
    0 comments No comments

  2. Salma 1 Reputation point
    2021-10-15T12:06:28.597+00:00

    did u solve this problem?
    I have the same, but I can't solve it.
    please answer me

    thanks

    0 comments No comments