Installing Microsoft Teams in Linux

json 21 Reputation points
2019-12-11T21:07:24.147+00:00

Any help on how to install/configure Microsoft Team in Linux

Skype for Business Linux
Skype for Business Linux
Skype for Business: A Microsoft communications service that provides communications capabilities across presence, instant messaging, audio/video calling, and an online meeting experience that includes audio, video, and web conferencing.Linux: A family of open-source Unix-like operating systems.
448 questions
{count} votes

Accepted answer
  1. Ricardo Havranek Garcia 81 Reputation points
    2019-12-12T15:43:47.38+00:00

    You can download the package here https://teams.microsoft.com/download, double click and follow the package manager instructions.


5 additional answers

Sort by: Most helpful
  1. OmarKhalidMSFT 6 Reputation points Microsoft Employee
    2019-12-11T21:36:12.987+00:00

    Installation can be executed from GUI or from terminal. When installation from GUI fails, it is a good idea to attempt the same action from the terminal where more verbose errors can be issued and more details obtained to unblock the installation.

    Debian based distributions (.deb)

    Install using apt:

    sudo apt install ./teams-insiders_1.2.00.26154_amd64.deb  
    

    RPM based distributions (.rpm)

    Option 1 - Using rpm:

    sudo rpm -i ./teams-insiders-1.2.00.26154-1.x86_64.rpm  
    

    Option 2 - Using yum (Recommended):

    sudo yum install ./teams-insiders-1.2.00.26154-1.x86_64.rpm  
    

    Dependencies issues can be similar to dpkg, rpm will try to install the package, but can complain about unmet dependencies, alternative is to use yum which will try to resolve the dependencies automatically.


  2. Ali Göktas 6 Reputation points
    2021-08-24T05:15:49.787+00:00

    Hi, I have been trying to install Teams but I get an error saying "Dependency is not satisfiable: libgtk-3-0 (>=3.19.12)" when I try to use the package installer interface. I tried installing from the terminal and this was the output:
    sudo apt install ./teams_1.4.00.13653_amd64.deb
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Note, selecting 'teams' instead of './teams_1.4.00.13653_amd64.deb'
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
     teams : Depends: libgtk-3-0 (>= 3.19.12) but 3.18.9-1ubuntu3.3 is to be installed
    E: Unable to correct problems, you have held broken packages.
    

    I tried running "sudo apt upgrade libgtk-3-0" and got this:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    libgtk-3-0 is already the newest version (3.18.9-1ubuntu3.3).
    Calculating upgrade... Done

    What can I do in this situation? I'm using Linux Mint 18.2, which is a Debian based system.


  3. json 21 Reputation points
    2019-12-12T19:21:36.437+00:00

    Can you kindly please advise, I'm getting this error

    (base) [root@btigenlx3 lib]# yum install ./teams-1.2.00.32451-1.x86_64.rpm
    Loaded plugins: langpacks, product-id, rhnplugin, search-disabled-repos, subscription-manager
    This system is receiving updates from RHN Classic or Red Hat Satellite.
    Examining ./teams-1.2.00.32451-1.x86_64.rpm: teams-1.2.00.32451-1.x86_64
    Marking ./teams-1.2.00.32451-1.x86_64.rpm to be installed
    Resolving Dependencies
    --> Running transaction check
    ---> Package teams.x86_64 0:1.2.00.32451-1 will be installed
    --> Processing Dependency: libstdc++.so.6(CXXABI_1.3.9)(64bit) for package: teams-1.2.00.32451-1.x86_64
    --> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.20)(64bit) for package: teams-1.2.00.32451-1.x86_64
    --> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.21)(64bit) for package: teams-1.2.00.32451-1.x86_64
    --> Finished Dependency Resolution

    Error: Package: teams-1.2.00.32451-1.x86_64 (/teams-1.2.00.32451-1.x86_64)
    Requires: libstdc++.so.6(GLIBCXX_3.4.21)(64bit)

    Error: Package: teams-1.2.00.32451-1.x86_64 (/teams-1.2.00.32451-1.x86_64)
    Requires: libstdc++.so.6(CXXABI_1.3.9)(64bit)

    Error: Package: teams-1.2.00.32451-1.x86_64 (/teams-1.2.00.32451-1.x86_64)
    Requires: libstdc++.so.6(GLIBCXX_3.4.20)(64bit)

    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest


  4. Definitely Ken 1 Reputation point
    2021-06-09T17:25:26.747+00:00

    This old problem reappeared today when trying to update "teams" from Microsoft's yum repository:

    Resolving Dependencies
    --> Running transaction check
    ---> Package teams.x86_64 0:1.4.00.13653-1 will be installed
    --> Processing Dependency: libstdc++.so.6(CXXABI_1.3.8)(64bit) for package: teams-1.4.00.13653-1.x86_64
    --> Processing Dependency: libstdc++.so.6(CXXABI_1.3.9)(64bit) for package: teams-1.4.00.13653-1.x86_64
    --> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.20)(64bit) for package: teams-1.4.00.13653-1.x86_64
    --> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.21)(64bit) for package: teams-1.4.00.13653-1.x86_64
    --> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.22)(64bit) for package: teams-1.4.00.13653-1.x86_64
    --> Finished Dependency Resolution
    Error: Package: teams-1.4.00.13653-1.x86_64 (teams-insiders)
    Requires: libstdc++.so.6(GLIBCXX_3.4.22)(64bit)
    Error: Package: teams-1.4.00.13653-1.x86_64 (teams-insiders)
    Requires: libstdc++.so.6(CXXABI_1.3.8)(64bit)
    Error: Package: teams-1.4.00.13653-1.x86_64 (teams-insiders)
    Requires: libstdc++.so.6(GLIBCXX_3.4.21)(64bit)
    Error: Package: teams-1.4.00.13653-1.x86_64 (teams-insiders)
    Requires: libstdc++.so.6(CXXABI_1.3.9)(64bit)
    Error: Package: teams-1.4.00.13653-1.x86_64 (teams-insiders)
    Requires: libstdc++.so.6(GLIBCXX_3.4.20)(64bit)
    You could try using --skip-broken to work around the problem