Unable to deploy Azure FarmBeats

Sunayana Singh 91 Reputation points
2020-05-29T06:53:07.893+00:00

Tried to deploy through Marketplace, end up with an empty Resource Group. Click through the Deployments to see two listed as successful, but when I try to drill down, the inputs/outs are empty. Also tried to deploy through CloudShell.

Error: Entry not found in cache. 
    at Logger.createError (/home/kris/farmbeats-installer/node_modules/adal-node/lib/log.js:216:13) 
    at TokenRequest.<anonymous> (/home/kris/farmbeats-installer/node_modules/adal-node/lib/token-request.js:526:40) 
    at /home/kris/farmbeats-installer/node_modules/adal-node/lib/token-request.js:148:20 
    at /home/kris/farmbeats-installer/node_modules/adal-node/lib/cache-driver.js:366:7 
    at /home/kris/farmbeats-installer/node_modules/adal-node/lib/cache-driver.js:301:7 
    at Request._callback (/home/kris/farmbeats-installer/node_modules/adal-node/lib/util.js:130:7) 
    at Request.self.callback (/home/kris/farmbeats-installer/node_modules/request/request.js:185:22) 
    at Request.emit (events.js:198:13) 
    at Request.<anonymous> (/home/kris/farmbeats-installer/node_modules/request/request.js:1161:10) 
    at Request.emit (events.js:198:13) 
Validating inputs. 
/home/kris/farmbeats-installer/publish/index.js:1252 
    const index = cachedAuthResponse.linkedSubscriptions.findIndex((x) => x.id === params.subscriptionId); 
TypeError: Cannot read property 'linkedSubscriptions' of null 
    at validateSubscriptionId (/home/kris/farmbeats-installer/publish/index.js:1252:38) 
    at getRequiredArguments (/home/kris/farmbeats-installer/publish/index.js:173:34) 
    at main (/home/kris/farmbeats-installer/publish/index.js:385:12) 
    at Object.<anonymous> (/home/kris/farmbeats-installer/publish/index.js:145:9) 
    at Module._compile (internal/modules/cjs/loader.js:778:30) 
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:789:10) 
    at Module.load (internal/modules/cjs/loader.js:653:32) 
    at tryModuleLoad (internal/modules/cjs/loader.js:593:12) 
    at Function.Module._load (internal/modules/cjs/loader.js:585:3) 
    at Function.Module.runMain (internal/modules/cjs/loader.js:831:12) 

Any assistance would be appreciated.

Not Monitored
Not Monitored
Tag not monitored by Microsoft.
23,913 questions
No comments
1 vote

Accepted answer
  1. Ashok Peddakotla 9,956 Reputation points Microsoft Employee
    2020-05-29T07:00:59.527+00:00

    Thanks for reaching out. Please try the following steps and let us know if it resolves the issue

    1. Run the deployment command again (wget - O) and when you reach the device login again try opening the URL in an incognito window to login.
    2. If the above doesn’t resolve the issue - Add “domainId” to your input json file and upload this file whenever you get faced with this issue. This field lets you specify a pertinent Azure tenant that you would like the installer to authenticate you into.
    No comments

0 additional answers

Sort by: Most helpful