Visual Studio Installer 2019

varie eventuali 21 Reputation points
2021-03-08T16:26:30.187+00:00

Hi,
I've been trying to install Visual Studio 2019 Community Edition for several days now, but without success.
I downloaded the vs_community__1114806224.1615192883.exe installation file.
The installation starts, at the end it closes without starting the installation program.
From the start menu, however, there is "Visual Studio Installer", launching it starts to load something but shortly after it freezes and shortly after it crashes.
I have Windows 10 version 20H2 build 19042.804, 8Gb Ram, 76Gb free on the hard disk, Intel (R) Core (TM) i3-2348M CPU @ 2.30GHz, 2300 Mhz, 2 cores, 4 logical processors.

I attach OneDrive link to the vslogs.zip file
https://1drv.ms/u/s!AlhT9n5n2UVshGCwIHI6uRwMV_Mo?e=K7WWEL

Please can you help me? I have tried many routes recommended in different posts, but none have been successful.

Thank you,
Giacomo

Visual Studio
Visual Studio
A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.
4,573 questions
0 comments No comments
{count} votes

Accepted answer
  1. Anna Xiu-MSFT 25,381 Reputation points Microsoft Vendor
    2021-03-09T08:28:05.427+00:00

    Hi @varie eventuali ,

    Welcome to Microsoft Q&A!

    Please view the similar issue: https://learn.microsoft.com/en-us/answers/questions/297414/visual-studio-community-2019-setup-closes-abruptly.html?childToView=298913#answer-298913

    You could try to run the following command line from the installer directory (C:\Program Files (x86)\Microsoft Visual Studio\Installer) to launch your Visual Studio Installer:
    vs_installer.exe --locale en-US

    Sincerely,
    Anna

    • If the answer is helpful, please click "Accept Answer" and upvote it.
      Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.
    1 person found this answer helpful.

1 additional answer

Sort by: Most helpful
  1. MPN 1 Reputation point
    2022-03-04T14:12:28.767+00:00

    Hi,

    I use Microsoft Deployment Tool for my Citric environment. I have a challenge deploying Visual Studio 2019 "SW_ELECTRONIC_Visual_Studio_Pro_2019_MultiLang_MLF_X22-02265"
    when i use the powerShell command as I do always for this purpose i get the install shield "Visual Studio Installer - Before you get started......."by using this line command:

    Below the script iI use for deployment:

    $Vendor = "Microsoft"
    $Product = "Visual Studio 2019"

    PowerShell Wrapper for MDT, Standalone and Chocolatey Installation - (C)2015 xenappblog.com

    Example 1: Start-Process "XenDesktopServerSetup.exe" -ArgumentList $unattendedArgs -Wait -Passthru

    Example 2 Powershell: Start-Process powershell.exe -ExecutionPolicy bypass -file $Destination

    Example 3 EXE (Always use ' '):

    $UnattendedArgs='/qn'

    (Start-Process "$PackageName.$InstallerType" $UnattendedArgs -Wait -Passthru).ExitCode

    Example 4 MSI (Always use " "):

    $UnattendedArgs = "/i $PackageName.$InstallerType ALLUSERS=1 /qn /liewa $LogApp"

    (Start-Process msiexec.exe -ArgumentList $UnattendedArgs -Wait -Passthru).ExitCode

    Write-Verbose "Setting Arguments" -Verbose
    $StartDTM = (Get-Date)

    $Vendor="Microsoft"
    $Product="Visal Studio 2019"
    $PackageName= "SW_ELECTRONIC_Visual_Studio_Pro_2019_MultiLang_MLF_X22-02265"
    $InstallerType="exe"
    $Version="02265"
    $LogPS = "${env:SystemRoot}" + "\Temp\$Vendor $Product $Version PS Wrapper.log"
    $LogApp = "${env:SystemRoot}" + "\Temp\$PackageName.log"
    $Destination = "${env:ChocoRepository}" + "\$Vendor\$Product\$Version\$packageName.$installerType"
    $UnattendedArgs='/s/q'

    Start-Transcript $LogPS

    CD Files

    Write-Verbose "Starting Installation of $Vendor $Product $Version" -Verbose
    (Start-Process "$PackageName.$InstallerType" $UnattendedArgs -Wait -Passthru).ExitCode

    Write-Verbose "Customization" -Verbose

    Write-Verbose "Stop logging" -Verbose
    $EndDTM = (Get-Date)
    Write-Verbose "Elapsed Time: $(($EndDTM-$StartDTM).TotalSeconds) Seconds" -Verbose
    Write-Verbose "Elapsed Time: $(($EndDTM-$StartDTM).TotalMinutes) Minutes" -Verbose
    Stop-Transcript

    I have tried many diffrent switches but every time I get the install shield with the answer "before you get started"

    Is there anybody who knows solving theis issue??

    I have used lot of sites ans help commands but non of them help me:

    https://learn.microsoft.com/en-us/visualstudio/install/use-command-line-parameters-to-install-visual-studio?view=vs-2022

    https://learn.microsoft.com/en-us/visualstudio/install/use-command-line-parameters-to-install-visual-studio?view=vs-2019

    C:\Users\administrator.FG\AppData\Local\Temp\72373373-eaed-4776-a788-449c357b312c\help.html

    I know that the install shiled prove the configuration but it must be possible to do it silient instead of using "continue" button which is not menaning using MDT

    Regards
    MPN

    0 comments No comments