Adding ws-addressing "To" in APIM policy set-header or set-body

nj_prnd 21 Reputation points

From APIM, I am calling a WCF backend service, which expects ws-addressing "To" set as default or to a certain value. Tried below combination but no luck <set-header name="Content-Type" exists-action="override"> <value>application/soap+xml; charset=utf-8; Action=""; To=""</value> </set-header> <set-header name="SOAPAction" exists-action="override"> <value></value> </set-header> <set-header name="SOAPTo" exists-action="override"> <value></value> </set-header> still get this error The message with To '' cannot be processed at the receiver, due to an AddressFilter mismatch at the EndpointDispatcher. Check that the sender and receiver's EndpointAddresses agree.

Azure API Management
Azure API Management
An Azure service that provides a hybrid, multi-cloud management platform for APIs.
1,230 questions
{count} votes

Accepted answer
  1. ChaitanyaNaykodi-MSFT 12,881 Reputation points Microsoft Employee

    Hello @nj_prnd ,
    You can try setting the <wsa:To> header in following manner.

            <set-body template="liquid">  
    			<soap:Envelope xmlns:soap="" xmlns="" >  
    				<soap:Header xmlns:wsa="">  

    Please let me know if there are any additional concerns, I will be glad to continue with our discussion. Thank you!

    0 comments No comments

1 additional answer

Sort by: Most helpful
  1. nj_prnd 21 Reputation points

    Thank you Chaitanya, this works.

    0 comments No comments