Azure Portal not show existing resources like Storage Accounts, VM's, Disk, etc

Oscar Aguilar 6 Reputation points

Conecting via Azure Portal my resources dissapear, them still exist because i can see them conecting via Powershell but for some reason Portal stop showing them, the only thing i can see in portal is my subscription.

Azure App Service
Azure App Service
Azure App Service is a service used to create and deploy scalable, mission-critical web apps.
4,967 questions
{count} vote

4 answers

Sort by: Most helpful
  1. Ronen Ariely 14,961 Reputation points MVP

    Hi @Oscar Aguilar ,

    1) Can you please confirm that you are using the right directory (Subscriptions are scoped to the selected directory and if you selected a different directory in the portal then you will not see the resources)

    When you go to the subscription blad using the link bellow, do you see your subscription?

    2) Can you please confirm that you are using the owner of the subscription same user which you used for the powershell check)

    2 people found this answer helpful.

  2. Ronen Ariely 14,961 Reputation points MVP

    Good day Oscar,

    I had several clients with the same issue.

    It always turned out to be a simple case id using filter options.

    Try to navigate to the "All resources" blade:

    On the top of the page you have option to use filters These filters impact other places in the portal. Make sure you clean all the filters by select "all" in all the filters.


  3. Md Asfaque 6 Reputation points

    Hey I am facing the same issue. My services are not showing in my Resource Group. What shall I do? Tried all the methods stated above but none worked.

    0 comments No comments

  4. Michel Caron 0 Reputation points

    I constantly get that problem. Doing a MS Learn and create a resource in a Concierge Subscription. I can go to the resource. I can see the resource on the home screen in recent. If I go on All Resources with no filter, the resource is not there. If I go back to the resource from the recent, and click on the resource group of the resource, the resource group do not list the resource.... If a click refreshes a dozen time a display to show "simplified view" show up and magically a view that list all the resource show. If I go back to the other view, it disappears again and no possibility to get that "simplified view" again...

    Eventually, after 20-30 minutes the resource will finally show correctly everywhere...

    I experience this for months, and it seems that problem existed for years... its impressive how many little bugs like this MS keep unfixed in all their lineup of product these days....


    0 comments No comments