Error while trying to import an custom vision project

TolgaE 1 Reputation point


I have been using this documentation: to move my project from one Azure Account to another.

After succesfully retrieving the information needed to import the project I get the following error:

"code": "BadRequestInvalidImportToken",
"message": "Import token was not valid."

I have tried to import the project via Postman, cURL and via the microsoft site itself.

I am pretty certain the token is valid and have no idea why the import does not work. It also does not work when I enter the subscription key and endpoint of the source account. I still get the same error.

the POST (edited for sensitive information) I try to do is:

Azure Custom Vision
Azure Custom Vision
An Azure artificial intelligence service and end-to-end platform for applying computer vision to specific domains.
142 questions
{count} votes

2 answers

Sort by: Most helpful
  1. romungi-MSFT 32,926 Reputation points Microsoft Employee

    @TolgaE I have tried to import a project using the steps from the document with curl and it seems to work as expected.


    I think the reason for your error could be the SAS token might be expired. If you could copy your token and paste it in a browser window it should download a project info file, if it fails though a new token might be required.

    1 person found this answer helpful.

  2. Tom Jenkins 46 Reputation points

    I have the same problem.
    I trained an object detection model with images. I used two tags.

    Then I removed one tag and tried to retrain it. The training was not possible. I added the Tag again and the training was sucessful.

    Then I tried to move the project to another ressouce. First try it was not possible. A week later i tried again and it worked, but some iterations were missing.
    I retrained the incompletely-moved model and deleted the original project.

    Now i wanted to move the retrained model to still another ressource. When trying to export the model i get an error:
    "Cannot export a project that has not been successfully created. Current project Status is: ImportingFailed."}* Connection #0 to host XXX left intact.

    Is there a chance to fix it?