Sharepoint 2016 & 2019 - "Open in Explorer" not working in Edge IEMode

Jussi Lehti 601 Reputation points
2021-03-10T07:03:39.187+00:00

I got this Edge IEMode working in my SP2019 dev farm and the site loads inside Edge in IE Mode, but the "Open in Explorer"-function just redirects me to a page where I could download Onedrive.

I thought that was just a gimmick that MS did with SP2019, but I also tried this with my SP2016 dev farm and same happens there so it has to be Edge-related limitation.

So why it does not work in IEMode even the Active X controls are supported in IEMode according to this documentation: https://learn.microsoft.com/en-us/deployedge/edge-ie-mode

SharePoint Server
SharePoint Server
A family of Microsoft on-premises document management and storage systems.
2,291 questions
SharePoint Server Management
SharePoint Server Management
SharePoint Server: A family of Microsoft on-premises document management and storage systems.Management: The act or process of organizing, handling, directing or controlling something.
2,889 questions
0 comments No comments
{count} votes

Accepted answer
  1. Jussi Lehti 601 Reputation points
    2021-03-12T12:34:47.747+00:00

    If I want to use "Open in explorer" function in my server I am obviously using Windows Server (2016) with Desktop Experience.

    However now I remembered a feature called "Desktop experience" from Windows Server 2012 R2 which needed to be installed for Webdav functions to work and that feature is now called "Webdav redirector" in Windows Server 2016" and I didn't have that installed.

    So I just installed that "Webdav redirector" feature and rebooted and then "Open in explorer" function worked in IEMode inside Edge.

    But that only works if I set my Sharepoint site to run in IE10 document mode in the xml file that Edge IEMode uses. In IE11 document mode that "Open in Explorer" button doesn't do anything.

    And it was a surprise that Internet Explorer seems to behave the same way. IE10 document mode works, but IE11 doesn't.


1 additional answer

Sort by: Most helpful
  1. ChelseaWu-MSFT 6,316 Reputation points
    2021-03-11T06:02:58.157+00:00

    What is the Operating System version you are using for your SharePoint farm(s)?
    Is it possible for you to test with “Open in Explorer” function with Internet Explorer directly on your SharePoint Server 2016 farm?

    The problem is not with the version of SharePoint or Edge, but version of OS of your farm.
    Open in Explorer” function (without using OneDrive or Groove) requires Desktop Experience feature, which is not provided with a separate installation option on Windows Server 2016 and later.
    When you install Windows Server 2016 using the Setup wizard, you can choose between Windows Server 2016 and Windows Server (Server with Desktop Experience). Without making a choice in the Setup wizard, Windows Server 2016 is installed; this is the Server Core installation option (without Desktop Experience feature).

    See the reference here: Install Server with Desktop Experience.

    If you are using Windows Server (Server with Desktop Experience), here is the document you can refer to for further troubleshooting: Troubleshoot "Open with Explorer" issues in SharePoint Online.


    If an Answer is helpful, please click "Accept Answer" and upvote it.
    **Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread. **

    0 comments No comments