“Can’t reach this page” when browsing localhost on Team Foundation Server website host

ME 306 Reputation points

I am using IIS10 and TFS2018, running on Windows Server 2019.

What I am ultimately trying to do is set the attachment size, which would use this URL:


This doesn't work, however.

The actual website is up - it's running in IIS and I can get to the real user-facing data from any workstation on the network. I'm not able to access it from the IIS / TFS host, however, either by that specific URL or going into IIS and trying to "Browse" the website through the IIS console. Unfortunately this is the only way to set the max file size from what I can tell.

I only get:

Can’t reach this page

•Make sure the web address is correct

•Search for this site on Bing

•Refresh the page

The website in question uses SSL, so out of curiosity I tried https:// version of that URL, as well as even a variant with both https:// and :443. I've also just tried leaving the port off, to no avail.

The host uses a proxy, which I've disabled to no avail (it is set to bypass said proxy for local addresses, and even has explicit exceptions for localhost and its own IP address besides). This doesn't help.

What could be preventing me from browsing the website itself on its own host if I'm able to access it elsewhere? There isn't a whole lot of information to try and troubleshoot this with that I'm able to find, and the server itself is not forthcoming.

Internet Information Services
0 comments No comments
{count} votes

Accepted answer
  1. ME 306 Reputation points

    There were several things that needed to happen in order to fix this:

    Configure Loopback settings correctly: https://learn.microsoft.com/en-us/troubleshoot/windows-server/networking/accessing-server-locally-with-fqdn-cname-alias-denied

    Disable "Enhanced Protection Mode" on Internet Explorer.

    Configure Group Policy to allow users to bypass bad certificates.

    In my case, #3 was required because the machine cert has a Principal Name that matches the machine's hostname, but the website name is slightly different and thus it thinks it's wrong.

    Additionally, Microsoft Guidance claims you can access the site with localhost as the hostname, but this never worked - I was only able to get this to work when using the website's actual name.

    0 comments No comments

0 additional answers

Sort by: Most helpful