Fix Intelisense alert "Invalid object name" with SSMS

RH 96 Reputation points
2020-06-01T03:56:05.137+00:00

I'm writing SQL in SSMS.

I'm getting the value from the link server, but the [LINK SERVER].[DB].[dbo].[TABLE] string is marked with a red wavy under line.

※However, the execution itself is successful.

I want to get solution of this, but how do I do it?

Please any help will be appreciate, Thank you.

Not Monitored
Not Monitored
Tag not monitored by Microsoft.
37,573 questions
0 comments No comments
{count} votes

3 additional answers

Sort by: Most helpful
  1. Leon Laude 85,716 Reputation points
    2020-06-01T06:34:44.89+00:00

    Hi,

    Q&A currently supports the products listed over here https://learn.microsoft.com/en-us/answers/products (more to be added later on).

    You can reach the experts in the dedicated SQL Server forum over here:
    https://social.technet.microsoft.com/Forums/en-US/home?category=sqlserver

    (Please don't forget to accept helpful replies as answer)

    Best regards,
    Leon

    0 comments No comments

  2. RH 96 Reputation points
    2020-06-01T07:46:20.303+00:00

    Hi,

    I see.

    I posted a question to TechNet.
    If I can get a solution, I'll include it here.

    Thank you.

    0 comments No comments

  3. Vaibhav Chaudhari 38,681 Reputation points
    2020-06-01T12:05:44.58+00:00

    Try pressing Ctrl + Shift + R key and see if that's solves. This combination of keys refreshes intellisense.


    If the response helped, do "Accept Answer" and upvote it - Vaibhav