“a specified logon session does not exist. it may already have been terminated”

Eduard Paul 1 Reputation point

a specified logon session does not exist. it may already have been terminated - after i joined the device to azure active directory

-i cannot access our shared folder in our server after i joined the device to azure AD and use office 365 account (Please see click the link below to see the error image for your reference), but if i use local administrator of the device i can access the file server using the credentials with no problem, please note that we dont have an premises active directory or GPO, kindly help me.

a specified logon session does not exist. it may already have been terminated

Azure Active Directory
Azure Active Directory
An Azure enterprise identity service that provides single sign-on and multi-factor authentication.
14,620 questions
0 comments No comments
{count} votes

5 answers

Sort by: Most helpful
  1. John Turcich 71 Reputation points

    I had this problem with a mapped drive to a NAS for a user. I added the name of the NAS as the domain name before his logon name "NASNAME\LOGONNAME" that appears to disconnect it from the AZURE directory and the drive mapped.

    14 people found this answer helpful.

  2. Gary Ford 30 Reputation points

    Honestly, I am very frustrated with the way Microsoft keeps breaking basic interoperability that has worked for ever. That being said, I have found that using '.' in front of the account will tell Windows this is a local user. i.e. '.\useraccount' will allow you to connect where 'useraccount' won't. That worked for me on my Azure AD joined workstation connecting to SMB shares on local NAS and Linux boxes.

    6 people found this answer helpful.

  3. Patrick H 1 Reputation point

    I have the exact same issue on all new desktop builds where I connect with an office 365 account. Instead of asking for a login it's asking for a pin. I've added credentials through the credential manager and disabled the hello pin feature. Still getting the same error message.

    0 comments No comments

  4. rome njaka 1 Reputation point

    I was able to solve this issue by simply starting my windows desktop with my 'administrator' account. I had done all the suggestions given and nothing worked. I even had to uninstall the last update I did for Windows 11 and it still didn't resolve it. But when the idea to try logging in with my 'Administrator' account hit, I was surprised it worked and angry (lol) at the amount of time wasted reading up so much diverse suggestions and none mentioning a login as Admin! I hope this works for others like me! :)

    0 comments No comments

  5. Rupin Kuruvilla 0 Reputation points

    Add share path in web credentials in the windows PC . before adding the username add the share path url removing the two \ . it works for me

    0 comments No comments