AKS Alert not triggering

JFMP 1 Reputation point

I set up an alert in AKS to detect when pod count is below 1. I use AZ portal. However the alert is never triggered.

I believe the signal is correct, as I can see the blue line going up and down when I modify the number of pods I wanna track. And I can see the threshold line is in between. So I cannot figure out why the signal would be wrong. I have tried different aggregations, by average, by total, still no trigger.

I also followed this: https://learn.microsoft.com/en-us/azure/azure-monitor/alerts/alerts-troubleshoot
Still, alert never triggered.

Any ideas on how to troubleshoot this issue?

More info: https://github.com/Azure/AKS/issues/2183

Azure Kubernetes Service (AKS)
Azure Kubernetes Service (AKS)
An Azure service that provides serverless Kubernetes, an integrated continuous integration and continuous delivery experience, and enterprise-grade security and governance.
1,333 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Monalla-MSFT 6,911 Reputation points Microsoft Employee

    @JFMP - Thanks for reaching out.

    I have tried to reproduce the scenario and its working fine without any issues.

    In order to find the root cause of it, we would need you to send us an email at AzCommunity@Microsoft.com by providing below details. 
    Subject : ATTN:Monika 

    1. Subscription ID 
    2. A link to this thread.
      Please email us these details and we will work with you closely to get this issue taken care of and also post any findings here in the thread so the community can benefit from it. 

    Thanks in advance. Looking forward for your email. 

    0 comments No comments

  2. JFMP 1 Reputation point


    I just sent it. Thank you.

    0 comments No comments