The administrative template file failed to be sent to the device. (ERROR CODE: 0x20101)

Dat Truong Manh 41 Reputation points
2021-03-12T04:59:07.853+00:00

Hi,
So I encounter this error code when verifying the installation status of Edge configuration profile to a Windows 10 Home Single Language device. This error however is not reproduced on other edition of Windows such as Edu, Pro or Enterprise. The only settings in the Edge configuration profile is URLBlocklist policy.

Device OS build is 19042.867, version 20H2 and MDM enrolled.
Edge version is 89.0.774.48 (64-bit).

There are another article about this issue but neither the cause or solution is provided.

Is there anything I can do to solve this issue?

Thank you,
Best regards.

Microsoft Intune Configuration
Microsoft Intune Configuration
Microsoft Intune: A Microsoft cloud-based management solution that offers mobile device management, mobile application management, and PC management capabilities.Configuration: The process of arranging or setting up computer systems, hardware, or software.
1,812 questions
Microsoft Intune
Microsoft Intune
A Microsoft cloud-based management solution that offers mobile device management, mobile application management, and PC management capabilities.
4,739 questions
{count} votes

Accepted answer
  1. Lu Dai-MSFT 28,366 Reputation points
    2021-03-23T05:02:40.19+00:00

    @Dat Truong Manh Thanks for your feedback.

    If you are interested in this feature on windows home device, it is suggested to feedback in intune user voice. This is a place to collect customers' requirements and problems.
    https://microsoftintune.uservoice.com/forums/291681-ideas

    At the same time, I will try my best to feedback to product team. However, I can't guarantee I'll get a reply from them.

    Thanks for understanding and have a nice day.


    If the response is helpful, please click "Accept Answer" and upvote it.

    1 person found this answer helpful.
    0 comments No comments

3 additional answers

Sort by: Most helpful
  1. Lu Dai-MSFT 28,366 Reputation points
    2021-03-15T06:14:10.767+00:00

    @Dat Truong Manh Thanks for your update.

    For this issue, I have done the test in my lab. The following pictures show my test:
    Device OS build is 19042.867,version 20H2 and MDM enrolled.
    Edge version is 89.0.774.54(64-bit)
    77617-image.png
    77643-image.png
    The profile is deployed successfully to my device group, and the URLs are blocked.
    77644-image.png
    77674-image.png

    So, we appreciate your help to try the following actions:

    1. Please update the Edge and deploy the profile again.
    2. Please enter "edge://policy" to check if there is any other policy causing this situation.
      77547-image.png

    If there is any update, feel free to let us know.


    If the response is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  2. Dat Truong Manh 41 Reputation points
    2021-03-15T07:26:30.963+00:00

    @Lu Dai-MSFT May I ask which edition of Windows you use in the screenshots? I find that this issue only occurs on Windows 10 Home, Home Single Language and Home N but not on Windows 10 Pro, Education or Enterprise regards the OS build number.

    I updated Edge to latest version, 89.0.774.54, but the issue remains the same. I verified that the version and OS build of the 2 test machines are identical, 20H2 and 19042.867, the only difference is their OS edition, one is Windows 10 Pro, and the other is Windows 10 Home Single Language.

    Furthermore, the configuration profile for Chrome ADMX behaving as Edge's, but Intune only displays Chrome's profile as "Not Applicable" with "No data".

    The followings are the screenshots from my test machines and Intune report.

    77648-image.png
    77657-image.png
    77658-image.png
    77659-image.png

    Is there anything more you need to help investigate?
    Best regards.


  3. Dat Truong Manh 41 Reputation points
    2021-03-22T10:04:44.78+00:00

    Update for the issue:
    I recently sent the ticket to Microsoft. They states that ADMX is not supported on Home edition, only Pro and Enterprise edition due to Group Policy Editor (gpedit.msc) is not available to Home edition devices: https://learn.microsoft.com/en-us/deployedge/configure-microsoft-edge
    80157-image.png

    So I conducted a test that if the GP Editor is enabled on a Home device, will the ADMX be successfully sent? Turns out the result is still the same as this issue.

    Maybe in the near future Microsoft might allow browser management on Home edition?

    0 comments No comments