Remote Desktop Error "You have been disconnected because another connection was made to the remote computer"

adamj999 11 Reputation points
2021-03-12T13:29:32.367+00:00

After applying the March 2021 updates to my Windows 10 20H2 home computer, I am unable to reconnect to my office computer which is also running Windows 10 20H2 and also received the March 2021 updates. I get the Remote Desktop Error "You have been disconnected because another connection was made to the remote computer"

This problem started yesterday morning. I generally connect to my office computer in the morning and disconnect in the evening. This has been working flawlessly for a year now. The problem only just started.

Yesterday, I found that I could reconnect sometime in the afternoon. I completed some work and disconnected again in the evening. This morning, when I tried to reconnect, I got the same error. Based on the message, it seems like part of the session is being held until it times out. I will see if I can reconnect again this afternoon.

My office PC is an AD Domain participant. My home PC is not. I typically use the Remote Desktop MS Store App to connect, which is up to date. However, I also tried connecting with the built-in Remote Desktop application and could not connect either.

I rebooted my home PC before attempting to reconnect. I also rebooted my remote PC yesterday, after I was able to reconnect in the afternoon. (I reconnected, rebooted, and reconnected again. Later that evening, I disconnected. This morning, I could not reconnect.)

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
11,119 questions
Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,382 questions
{count} vote

6 answers

Sort by: Most helpful
  1. Karlie Weng 16,081 Reputation points Microsoft Vendor
    2021-03-15T05:56:08.787+00:00

    Hello@adamj999

    This prompt means either someone else has forcefully knocked you out of your remote session (Desktop OS remote session only allow 1 session cocurrent) or you mistakenly remoted twice into the same computer and forcefully closed your original remote session.
    If you continue to encounter this error, you can check to see who is attempting to login and override your remote session in the remote machines using a command line command.

    1. Type the following command into Windows Command Prompt : quser
    2. This outputs the current logged in users.
      You can also search event viewer to find out the last logged in user.
      Open Event Viewer (Start -> type Event Viewer). Expand Windows Logs -> Security and search for Event ID 4624.
      This will display all login events on the machine. You can identify who is logging (Windows user ID) in around the time you are being kicked out.
    3. Check logs for remote desktop: Event Viewer - Applications and Services Logs, Microsoft, Windows, TerminalServices-RemoteConnectionManager, Operational
    4. A workaround I found online:
      Disable the "Restrict each user to a single session" setting on the remote machine via 'gpedit.msc', and go to the following location
      Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Connections
      Here you will need to change a setting called ‘Restrict Remote Desktop Services users to a single Remote Desktop Services session’ – set it to disabled.

    Best Regards
    Karlie

    ----------

    If the Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    5 people found this answer helpful.

  2. 767piloto 6 Reputation points
    2021-07-04T13:53:39.957+00:00

    Same problem suddenly appeared. Turns out the Netgear router (where port-forwarding was set up) reassigned the IP used by the Windows machine I was remote connecting to. After changing the port-forwarding IP to the one matching the Windows machine, it was back to working.

    Also, with most routers, you can assign which IP a given connection will use. This may prevent future problems...

    1 person found this answer helpful.

  3. Louis Tang 6 Reputation points
    2022-01-14T12:39:52.08+00:00

    I had this problem before.

    Method 1:
    Contact Microsoft.

    Method 2:
    I can connect and use the RDP. It necessary to use the RDP app on a phone and with a PC. When the RDP app is connecting fist, I press the connect button of RDP on the PC simultaneously and kick out the current user. It works for me.

    Method 3:
    The RDP becomes normal after I removed the auto login values in regedit.

    1 person found this answer helpful.
    0 comments No comments

  4. susanne c 1 Reputation point
    2021-04-26T07:50:11.46+00:00

    I had the same problem, running client on Windows 10. It was solved when adding my changed IP address to allowed connections on the server. Looks like the event description was out of range for me.

    0 comments No comments

  5. Glen Edwards 1 Reputation point
    2021-07-26T20:33:43.547+00:00

    "This prompt means either someone else has forcefully knocked you out of your remote session..."

    As it turns out the "other user" that locked me out was the firewall on the server computer. DHCP changed my local IP address, so my server slammed the door in my face. I updated the firewall; problem solved.